fix ipsec-tools (missing include, missing dependencies)
[openwrt/openwrt.git] / openwrt / package / ipsec-tools / Makefile
index 1a5ae5b4fd9cca5090d39e29b99dd3c59fa35b91..c1fe597a8cda22f44aa55c86cf94ea183390a6ec 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -15,11 +21,12 @@ PKG_CAT:=bzcat
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 define Package/ipsec-tools
 SECTION:=base
 CATEGORY:=Network
-DEPENDS:=@LINUX_2_6
+DEPENDS:=@LINUX_2_6 +libopenssl
 TITLE:=IPsec management tools
 DESCRIPTION:=IPsec management tools
 URL:=http://ipsec-tools.sourceforge.net/