normalize Makefiles.
[openwrt/openwrt.git] / openwrt / package / zd1211 / Makefile
index e73c0dc5221f83bf08a2fd4c7f9f9ef0adf7929d..a71873b9f7f678ac37192b52ddb395cc7bc0d703 100644 (file)
@@ -8,25 +8,25 @@ PKG_VERSION:=r69
 PKG_RELEASE:=1
 PKG_MD5SUM:=c14133a3d5b27927402a492e84d2467a
 
 PKG_RELEASE:=1
 PKG_MD5SUM:=c14133a3d5b27927402a492e84d2467a
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-driver-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://zd1211.ath.cx/download/
 PKG_SOURCE:=$(PKG_NAME)-driver-$(PKG_VERSION).tgz
 PKG_CAT:=zcat
 
 PKG_SOURCE_URL:=http://zd1211.ath.cx/download/
 PKG_SOURCE:=$(PKG_NAME)-driver-$(PKG_VERSION).tgz
 PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-driver-$(PKG_VERSION)
-
 include $(TOPDIR)/package/rules.mk
 
 include $(TOPDIR)/package/rules.mk
 
+#FIXME: add proper dependency handling on kmod-usb-core packages
 define Package/kmod-zd1211
 define Package/kmod-zd1211
- SECTION:=drivers
- CATEGORY:=Drivers
- DEPENDS:=@LINUX_2_6
- TITLE:=Driver for Zydas 1211 based USB devices
- DESCRIPTION:=Driver for Zydas 1211 based USB devices \\\
+SECTION:=drivers
+CATEGORY:=Drivers
+DEPENDS:=@LINUX_2_6
+TITLE:=Driver for Zydas 1211 based USB devices
+DESCRIPTION:=Driver for Zydas 1211 based USB devices \\\
 Linux driver for the ZyDAS ZD1211 802.11b/g USB-WLAN-Chip.\\\
 Initially contributed by ZyDAS, this driver is actively maintained by the \\\
 open source community.
 Linux driver for the ZyDAS ZD1211 802.11b/g USB-WLAN-Chip.\\\
 Initially contributed by ZyDAS, this driver is actively maintained by the \\\
 open source community.
- URL:=http://zd1211.ath.cx/
- VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+URL:=http://zd1211.ath.cx/
+VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
@@ -54,4 +54,3 @@ define Package/kmod-zd1211/install
 endef
 
 $(eval $(call BuildPackage,kmod-zd1211))
 endef
 
 $(eval $(call BuildPackage,kmod-zd1211))
-