don't pad aruba images - unnecessary with the jffs2 hack
[openwrt/openwrt.git] / openwrt / target / image / aruba / Makefile
index 1d2aebfb18236a47b9bdb4f0f72888017aea4f23..09aa8eabd4ac24eb77d72ac570709328681496ff 100644 (file)
@@ -33,8 +33,7 @@ endef
 define Image/Build/jffs2-64k
        @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=655360 conv=sync
        @cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
-       @dd if=$(KDIR)/image.tmp of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(patsubst jffs2-%,jffs2,$(1)).bin bs=3604480 conv=sync
-       @rm -f $(KDIR)/image.tmp
+       mv $(KDIR)/image.tmp $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(patsubst jffs2-%,jffs2,$(1)).bin
 endef
 
 define Image/Build