6to4: add netifd support
[openwrt/openwrt.git] / package / 6to4 / Makefile
index 8cf66c0a28db008fecb16afb05b4934ac98e77c4..45639646cc6325225fe73adaf2b2be61794b4530 100644 (file)
@@ -34,11 +34,20 @@ endef
 define Build/Configure
 endef
 
-define Package/6to4/install
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_DATA) ./files/6to4.sh $(1)/lib/network/6to4.sh
+ifneq ($(CONFIG_PACKAGE_netifd),)
+  define Package/6to4/install
+       $(INSTALL_DIR) $(1)/lib/netifd/proto
+       $(INSTALL_BIN) ./files/6to4.sh $(1)/lib/netifd/proto/6to4.sh
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_DATA) ./files/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
-endef
+  endef
+else
+  define Package/6to4/install
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_DATA) ./files.old/6to4.sh $(1)/lib/network/6to4.sh
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files.old/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
+  endef
+endif
 
 $(eval $(call BuildPackage,6to4))