Fix rt61 compilation with 2.6.19 kernels
[openwrt/openwrt.git] / package / Makefile
index e94c181ba023877de9b72d59ab426dd1a125e054..34eba4e3b1e75fdded00d13766f4607ad061756f 100644 (file)
@@ -8,8 +8,8 @@
 
 include $(TOPDIR)/rules.mk
 include $(TOPDIR)/.config
-include $(TOPDIR)/.pkgdeps
-include $(TOPDIR)/host.mk
+include $(TMP_DIR)/.pkgdeps
+include $(INCLUDE_DIR)/host.mk
 
 PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(prereq-y) $(prereq-m))
 DOWNLOAD_PACKAGES:=$(patsubst %,%-download,$(package-y) $(package-m))
@@ -41,7 +41,7 @@ ifeq ($(SDK),1)
 GENDEP_OPTS := -s
 endif
 
-$(TOPDIR)/.pkgdeps: $(TOPDIR)/.pkginfo
+$(TMP_DIR)/.pkgdeps: $(TMP_DIR)/.pkginfo
        @$(TOPDIR)/scripts/gen_deps.pl $(GENDEP_OPTS) < $< > $@ || rm -f $@
 
 all: compile
@@ -55,6 +55,16 @@ install-targets: base-files-install $(INSTALL_PACKAGES)
 install:
        rm -rf $(BUILD_DIR)/root
        $(MAKE) install-targets
+       @if [ -d $(TOPDIR)/files ]; then \
+               $(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
+       fi
+       @( \
+               cd $(BUILD_DIR)/root; \
+               for script in ./etc/init.d/*; do \
+                       grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
+                       IPKG_INSTROOT=$(BUILD_DIR)/root $(which bash) ./etc/rc.common $$script enable; \
+               done; \
+       )
 
 index: $(PACKAGE_DIR)/Packages