ar71xx: add support for the Allnet ALL0315N board
[openwrt/openwrt.git] / package / Makefile
index 3c7b0b49bc477b02a45d3aae27fd3201224596e0..5d942ca78391733b13ce1278de2408115c62b0f4 100644 (file)
@@ -12,13 +12,12 @@ $(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
 ifeq ($(SDK),1)
   $(curdir)/builddirs-install:=.
 else
-  $(curdir)/base-files/compile += $(curdir)/opkg/host/compile
   $(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
   $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
-  $(curdir)/builddirs-install:=. $(sort $(package-y))
+  $(curdir)/builddirs-install:=. $(filter-out base-files,$(sort $(package-y))) $(filter base-files,$(package-y))
 endif
 ifneq ($(IGNORE_ERRORS),)
-  $(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
+  $(curdir)/builddirs-ignore-compile:= $(if $(filter n m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(subst n,,$(m)))),$(package-m) $(package-))
 endif
 
 $(curdir)/install:=$(curdir)/install-cleanup
@@ -39,7 +38,7 @@ ifdef CONFIG_USE_MKLIBS
                file -r -N -F '' {} + | \
                awk ' /shared object/ { print $$1 }' >> $(TMP_DIR)/mklibs-progs
        mkdir -p $(TMP_DIR)/mklibs-out
-       $(STAGING_DIR_HOST)/bin/mklibs.py -D \
+       $(STAGING_DIR_HOST)/bin/mklibs -D \
                -d $(TMP_DIR)/mklibs-out \
                --sysroot $(STAGING_DIR_ROOT) \
                -L /lib \
@@ -65,6 +64,14 @@ endif
 $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
        @-$(MAKE) package/preconfig
        @if [ -d $(TOPDIR)/files ]; then \
+               ( cd $(TOPDIR)/files; find -type f ) | \
+                       ( cd $(TARGET_DIR); while :; do \
+                               read FILE; \
+                               [ -z "$$FILE" ] && break; \
+                               [ -L "$$FILE" ] || continue; \
+                               echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
+                               rm -f "$$FILE"; \
+                       done; ); \
                $(CP) $(TOPDIR)/files/. $(TARGET_DIR); \
        fi
        @mkdir -p $(TARGET_DIR)/etc/rc.d
@@ -78,20 +85,21 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
        @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
+       rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.postinst
        $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/opkg)
        $(call mklibs)
 
 $(curdir)/index: FORCE
-       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
                gzip -9c Packages > Packages.gz \
        )
 
 $(curdir)/flags-install:= -j1
 
 $(eval $(call stampfile,$(curdir),package,prereq,.config))
-$(eval $(call stampfile,$(curdir),package,cleanup))
-$(eval $(call stampfile,$(curdir),package,compile))
-$(eval $(call stampfile,$(curdir),package,install))
-$(eval $(call stampfile,$(curdir),package,rootfs-prepare))
+$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,rootfs-prepare,$(TMP_DIR)/.build))
 
 $(eval $(call subdir,$(curdir)))