ar71xx: add support for the Allnet ALL0315N board
[openwrt/openwrt.git] / package / Makefile
index 4f2cbf106ebf2ac650d1b59a4202e1c27f28aef4..5d942ca78391733b13ce1278de2408115c62b0f4 100644 (file)
@@ -14,7 +14,7 @@ ifeq ($(SDK),1)
 else
   $(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
   $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
-  $(curdir)/builddirs-install:=. $(sort $(package-y))
+  $(curdir)/builddirs-install:=. $(filter-out base-files,$(sort $(package-y))) $(filter base-files,$(package-y))
 endif
 ifneq ($(IGNORE_ERRORS),)
   $(curdir)/builddirs-ignore-compile:= $(if $(filter n m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(subst n,,$(m)))),$(package-m) $(package-))
@@ -38,7 +38,7 @@ ifdef CONFIG_USE_MKLIBS
                file -r -N -F '' {} + | \
                awk ' /shared object/ { print $$1 }' >> $(TMP_DIR)/mklibs-progs
        mkdir -p $(TMP_DIR)/mklibs-out
-       $(STAGING_DIR_HOST)/bin/mklibs.py -D \
+       $(STAGING_DIR_HOST)/bin/mklibs -D \
                -d $(TMP_DIR)/mklibs-out \
                --sysroot $(STAGING_DIR_ROOT) \
                -L /lib \