fix multiport netfilter module installation (patch from #1280)
[openwrt/openwrt.git] / package / Makefile
index eafd8cbe6e75f7b12553a147132e461dc9a6c9ff..d21fedf31becb42d4de8d2fedc3a54b54188554d 100644 (file)
@@ -50,7 +50,9 @@ prereq: $(PREREQ_PACKAGES)
 download: $(DOWNLOAD_PACKAGES)
 compile-targets: $(COMPILE_PACKAGES)
 compile:
+       @-rm -f $(PACKAGE_DIR)/*.ipk
        $(MAKE) compile-targets
+
 install-targets: $(INSTALL_PACKAGES)
 install:
        rm -rf $(BUILD_DIR)/root
@@ -71,6 +73,8 @@ index: $(PACKAGE_DIR)/Packages
 $(PACKAGE_DIR)/Packages: $(PACKAGE_DIR)/*.ipk
        (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
 
+symlinks:
+       ../scripts/feeds.sh $(CONFIG_SOURCE_FEEDS) 
 
 ifeq ($(MAKECMDGOALS),compile-targets)
 MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)