add preliminary coldfire v4e support
[openwrt/openwrt.git] / package / base-files / Makefile
index 8a5f67b42fcf4b0c526eb3adf696c54a3acb17f8..69f1e776c2e976df8377a91c08f42c683444e78b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=19
+PKG_RELEASE:=23
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
@@ -24,7 +24,7 @@ ifneq ($(DUMP),1)
   ifeq ($(ARCH),x86_64)
     LIB_SUFFIX:=64
   endif
-  ifeq ($(ARCH),mips64)
+  ifneq ($(findstring mips64,$(ARCH)),)
     LIB_SUFFIX:=64
   endif
 else
@@ -74,7 +74,7 @@ endef
 define Package/libgcc
 $(call Package/gcc/Default)
   TITLE:=GCC support library
-  DEPENDS+=@!TARGET_avr32
+  DEPENDS+=@!(TARGET_avr32||TARGET_coldfire)
 endef
 
 define Package/libssp