include/feeds.mk: rework generation of opkg distfeeds.conf
[openwrt/openwrt.git] / package / base-files / image-config.in
index 45ca1306f7d7f94594c8fe6e1d96169b940501c0..cee8cd54e1239a3dd424fa86df8fac3eaa1d31b8 100644 (file)
@@ -163,13 +163,6 @@ if VERSIONOPT
                        This is the name of the release distribution.
                        If unspecified, it defaults to OpenWrt.
 
-       config VERSION_NICK
-               string
-               prompt "Release version nickname"
-               help
-                       This is the release codename embedded in the image.
-                       If unspecified, it defaults to the name of source branch.
-
        config VERSION_NUMBER
                string
                prompt "Release version number"
@@ -190,7 +183,7 @@ if VERSIONOPT
        config VERSION_REPO
                string
                prompt "Release repository"
-               default "http://downloads.lede-project.org/snapshots"
+               default "http://downloads.openwrt.org/releases/18.06-SNAPSHOT"
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders:
@@ -275,18 +268,4 @@ menuconfig PER_FEED_REPO
                If set, a separate repository is generated within bin/*/packages/
                for the core packages and each enabled feed.
 
-       config PER_FEED_REPO_ADD_DISABLED
-               bool "Add available but not enabled feeds to opkg.conf"
-               default y
-               depends on PER_FEED_REPO
-               help
-                 Add not installed or disabled feeds from feeds.conf to opkg.conf.
-
-       config PER_FEED_REPO_ADD_COMMENTED
-               bool "Comment out not enabled feeds"
-               default !BUILDBOT
-               depends on PER_FEED_REPO && PER_FEED_REPO_ADD_DISABLED
-               help
-                 Add not enabled feeds as commented out source lines to opkg.conf.
-
 source "tmp/.config-feeds.in"