u-boot,at91bootstrap: fix incorrect HOSTCPPFLAGS variable
[openwrt/openwrt.git] / package / boot / at91bootstrap / at91bootstrap.mk
index 732d643aa66527bfdd61b0afbfd168fb5533d298..92353ff969932f24f14cbb38eebe03bad4b57356 100644 (file)
@@ -1,6 +1,15 @@
 
+PKG_TARGETS := bin
+PKG_FLAGS:=nonshared
+
 export GCC_HONOUR_COPTS=s
 
+define Package/at91bootstrap/install/default
+  $(CP) $(PKG_BUILD_DIR)/binaries/*uboot* $(1)/
+endef
+
+Package/at91bootstrap/install = $(Package/at91bootstrap/install/default)
+
 define AT91Bootstrap/Init
   BUILD_TARGET:=
   BUILD_SUBTARGET:=
@@ -17,7 +26,7 @@ TARGET_DEP = TARGET_$(BUILD_TARGET)$(if $(BUILD_SUBTARGET),_$(BUILD_SUBTARGET))
 
 AT91BOOTSTRAP_MAKE_FLAGS = \
        HOSTCC="$(HOSTCC)" \
-       HOSTCFLAGS='$(HOST_CFLAGS) $$$$(HOSTCPPFLAGS)' \
+       HOSTCFLAGS="$(HOST_CFLAGS) $(HOST_CPPFLAGS)" \
        HOSTLDFLAGS=""
 
 define Build/AT91Bootstrap/Target
@@ -46,8 +55,7 @@ define Build/AT91Bootstrap/Target
   endef
 
   define Package/at91bootstrap-$(1)/install
-    $(CP) $(PKG_BUILD_DIR)/binaries/*uboot*.bin \
-      $(BIN_DIR)/at91bootstrap-$(1).bin
+    $$(Package/at91bootstrap/install)
   endef
 endef