fconfig: cleanup Makefile
[openwrt/openwrt.git] / package / boot / fconfig / Makefile
index 3c33d73c6920478b004b962e58cae0e481e65823..9b806fe97cd0ff5de92b3192d0b1df1d31281789 100644 (file)
@@ -12,7 +12,7 @@ PKG_VERSION:=20080329
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://andrzejekiert.ovh.org/software/fconfig/
+PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
 PKG_HASH:=4ff0e8f07e35e46b705c0dbe9d9544ede01ea092a69e3f7db03e55a3f2bb8eb7
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
@@ -24,20 +24,12 @@ define Package/fconfig
   CATEGORY:=Utilities
   SUBMENU:=Boot Loaders
   TITLE:=RedBoot configuration editor
-  URL:=http://andrzejekiert.ovh.org/software.html.en
 endef
 
 define Package/fconfig/description
        displays and (if writable) also edits the RedBoot configuration.
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile
-       $(call Build/Compile/Default)
-endef
-
 define Package/fconfig/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/fconfig $(1)/usr/sbin/