layerscape: add armv7 subtarget and ls1021atwr board support
[openwrt/openwrt.git] / package / boot / uboot-layerscape / Makefile
index ffa392cd6e6b3834d8612735ace2f4b3532ac7f1..875e08f0e128a05ae90e5a081010241035f90957 100644 (file)
@@ -59,13 +59,21 @@ define U-Boot/ls2088ardb
   UBOOT_CONFIG:=ls2080ardb
 endef
 
+define U-Boot/ls1021atwr
+  NAME:=NXP LS1021ATWR
+  BUILD_SUBTARGET:=armv7
+  UBOOT_CONFIG:=ls1021atwr_nor
+  ENV_SIZE:=0x20000
+endef
+
 UBOOT_TARGETS := \
   ls1012ardb \
   ls1012afrdm \
   ls1043ardb \
   ls1046ardb \
   ls1088ardb \
-  ls2088ardb
+  ls2088ardb \
+  ls1021atwr
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)