treewide: clean up download hashes
[openwrt/openwrt.git] / package / boot / uboot-oxnas / Makefile
index aee7808c513b92f39e68148729046ab0dabf2323..d76af0ac1339ae0883a38e8124ac96cf9ef11aa7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2014.04
+PKG_VERSION:=2014.10
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
 
-PKG_MD5SUM:=6d2116d1385a66e9a59742caa9d62a54
+PKG_HASH:=d3b132a7a9b3f3182b7aad71c2dfbd4fc15bea83e12c76134eb3ffefc07d1c71
 
 PKG_LICENSE:=GPL-2.0 GPL-2.0+
 PKG_LICENSE_FILES:=Licenses/README
@@ -82,6 +82,8 @@ define Package/uboot/install/default
        $(INSTALL_DIR) $(BIN_DIR)
        $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
                $(BIN_DIR)/openwrt-$(BOARD)-$(1)-u-boot.bin
+       $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
+               $(KERNEL_BUILD_DIR)/u-boot.bin
 endef
 
 define Package/uboot/install/template