sunxi: add support for Banana Pi M2 Berry
[openwrt/openwrt.git] / package / boot / uboot-sunxi / Makefile
index 18288cdd3a6c0b483e141424d3991852fb258d91..66ca07fa12f69039242e9f01258c9b9f67e0892a 100644 (file)
@@ -204,6 +204,15 @@ define U-Boot/orangepi_one
   BUILD_DEVICES:=xunlong_orangepi-one
 endef
 
+define U-Boot/orangepi_one_plus
+  BUILD_SUBTARGET:=cortexa53
+  NAME:=Orange Pi One Plus (H6)
+  DEPENDS:=+PACKAGE_u-boot-orangepi_one_plus:arm-trusted-firmware-sunxi-h6
+  BUILD_DEVICES:=xunlong_orangepi-one-plus
+  UENV:=h6
+  ATF:=h6
+endef
+
 define U-Boot/orangepi_pc
   BUILD_SUBTARGET:=cortexa7
   NAME:=Orange Pi PC (H3)
@@ -310,6 +319,12 @@ define U-Boot/Bananapi_M2_Ultra
   BUILD_DEVICES:=sinovoip_bananapi-m2-ultra
 endef
 
+define U-Boot/bananapi_m2_berry
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=Bananapi M2 Berry
+  BUILD_DEVICES:=sinovoip_bananapi-m2-berry
+endef
+
 UBOOT_TARGETS := \
        a64-olinuxino \
        a64-olinuxino-emmc \
@@ -321,6 +336,7 @@ UBOOT_TARGETS := \
        A20-OLinuXino_MICRO \
        bananapi_m2_plus_h3 \
        Bananapi \
+       bananapi_m2_berry \
        Bananapi_M2_Ultra \
        Bananapro \
        Cubieboard \
@@ -344,6 +360,7 @@ UBOOT_TARGETS := \
        orangepi_zero \
        orangepi_r1 \
        orangepi_one \
+       orangepi_one_plus \
        orangepi_pc \
        orangepi_pc_plus \
        orangepi_plus \