sunxi: build image/uboot for the NanoPi NEO2
[openwrt/openwrt.git] / package / boot / uboot-sunxi / Makefile
index ce5edfc1b62c4b7833e58e3ac257f9d633bbfed5..b3d9c1eb69a700a3a63fdb7f9b96eae002c367bc 100644 (file)
@@ -182,6 +182,14 @@ define U-Boot/nanopi_neo_plus2
   UENV:=a64
 endef
 
+define U-Boot/nanopi_neo2
+  BUILD_SUBTARGET:=cortexa53
+  NAME:=NanoPi NEO2 (H5)
+  BUILD_DEVICES:=sun50i-h5-nanopi-neo2
+  DEPENDS:=+PACKAGE_u-boot-nanopi_neo2:arm-trusted-firmware-sunxi
+  UENV:=a64
+endef
+
 define U-Boot/pine64_plus
   BUILD_SUBTARGET:=cortexa53
   NAME:=Pine64 Plus A64
@@ -237,6 +245,7 @@ UBOOT_TARGETS := \
        nanopi_m1_plus \
        nanopi_neo \
        nanopi_neo_plus2 \
+       nanopi_neo2 \
        orangepi_r1 \
        orangepi_pc \
        orangepi_plus \