uboot-zynq: fix compile error for be short of dtc
[openwrt/openwrt.git] / package / boot / uboot-zynq / Makefile
index 412415bfc6283f45ef3e3c33abd49e25b51c4b3e..a6e4f0a715a8a4b275a478a18ac1fa89323a41cb 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 include $(TOPDIR)/rules.mk
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
 
 PKG_NAME:=u-boot
 PKG_VERSION:=2016.03
 
 PKG_NAME:=u-boot
 PKG_VERSION:=2016.03
@@ -81,7 +82,7 @@ endef
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               CROSS_COMPILE=$(TARGET_CROSS)
+               CROSS_COMPILE=$(TARGET_CROSS) DTC=$(LINUX_DIR)/scripts/dtc/dtc
 endef
 
 define Package/uboot/install/default
 endef
 
 define Package/uboot/install/default