remove linux 2.4 support from several packages
[openwrt/openwrt.git] / package / bridge-utils / Makefile
index de9bc95d7ab957414002c96b4e9fe97f2dd5ac51..0b6eaecb8752755f375f33feea76929c9150073a 100644 (file)
@@ -4,19 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=bridge-utils
-PKG_VERSION:=1.4
 PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/bridge
+PKG_VERSION:=1.4
 PKG_MD5SUM:=0182fcac3a2b307113bbec34e5f1c673
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/bridge
@@ -34,10 +33,13 @@ endef
 CONFIGURE_ARGS += \
        --with-linux-headers="$(LINUX_DIR)" \
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-       autoconf; \
-       ./configure $(CONFIGURE_ARGS) \
+define Build/Prepare
+$(call Build/Prepare/Default)
+       ( cd $(PKG_BUILD_DIR) ; \
+               [ -f ./configure ] || { \
+                       ln -sf configure.in configure.ac ; \
+                       autoconf ; \
+               } \
        )
 endef