ath9k: fix various calibration related bugs and clean up the code
[openwrt/openwrt.git] / package / busybox / Makefile
index 43da0a48deb7e22c26052734ceadcec517925ac8..128a0dea180f5a1cbe1dbccc303c19698608f16f 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.15.3
+PKG_VERSION:=1.16.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=6059ac9456de6fb18dc8ee4cd0ec9240
+PKG_MD5SUM:=2ba980f720a5bdce4ec05423519acc35
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,6 +30,7 @@ init-$(CONFIG_BUSYBOX_CONFIG_TELNETD) += telnet
 define Package/busybox
   SECTION:=base
   CATEGORY:=Base system
+  MAINTAINER:=Nicolas Thill <nico@openwrt.org>
   TITLE:=Core utilities for embedded Linux
   URL:=http://busybox.net/
   MENU:=1
@@ -41,11 +42,7 @@ define Package/busybox/description
 endef
 
 define Package/busybox/config
-       menu "Configuration"
-               depends on PACKAGE_busybox
-               source "$(SOURCE)/target-config.in"
-               source "$(SOURCE)/config/Config.in"
-       endmenu
+       source "$(SOURCE)/Config.in"
 endef
 
 define Build/Configure
@@ -63,6 +60,10 @@ ifdef CONFIG_GCC_VERSION_LLVM
   TARGET_CFLAGS += -fnested-functions
 endif
 
+ifdef CONFIG_GCC_VERSION_4_5_0
+  TARGET_CFLAGS += -fno-tree-pta
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
@@ -70,6 +71,7 @@ define Build/Compile
                KBUILD_HAVE_NLS=no \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
                ARCH="$(ARCH)" \
+               SKIP_STRIP=y \
                all
        rm -rf $(PKG_INSTALL_DIR)
        $(FIND) $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
@@ -78,7 +80,6 @@ define Build/Compile
                CROSS_COMPILE="$(TARGET_CROSS)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
                ARCH="$(ARCH)" \
-               IPKG_ARCH="$(ARCH)" \
                CONFIG_PREFIX="$(PKG_INSTALL_DIR)" \
                install
 endef