fix PACKAGES:= for target profiles in target.mk
[openwrt/openwrt.git] / package / dropbear / Makefile
index 546facf9239839606b53b20594d52da18886d2cd..60625947af3a9d5e0afe14c46a8059905191bf0c 100644 (file)
@@ -9,15 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=0.48.1
-PKG_RELEASE:=1
+PKG_VERSION:=0.49
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/
-PKG_MD5SUM:=ca8e53a766faec831882831364568421
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/ \
+                               http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
+PKG_MD5SUM:=7b20c85f1ee34f018a1b948eae003df9
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,7 +27,6 @@ define Package/dropbear
   $(call Package/dropbear/Default)
   SECTION:=net
   CATEGORY:=Base system
-  DEFAULT:=y
   TITLE:=Small SSH2 client/server
   DESCRIPTION:=\
        A small SSH2 server/client designed for small memory environments.
@@ -42,47 +39,26 @@ define Package/dropbearconvert
   TITLE:=Utility for converting SSH keys
 endef
 
+CONFIGURE_ARGS += \
+       --with-shared \
+       --disable-pam \
+       --enable-openpty \
+       --enable-syslog \
+       --disable-shadow \
+       --disable-lastlog \
+       --disable-utmp \
+       --disable-utmpx \
+       --disable-wtmp \
+       --disable-wtmpx \
+       --disable-loginfunc \
+       --disable-pututline \
+       --disable-pututxline \
+       --disable-zlib
+
 define Build/Configure
        $(SED) 's,^/\* #define PKG_MULTI.*,#define PKG_MULTI,g' $(PKG_BUILD_DIR)/options.h
        $(SED) 's,^#define DO_HOST_LOOKUP,/* & */,g' $(PKG_BUILD_DIR)/options.h
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --with-shared \
-                       --disable-pam \
-                       --enable-openpty \
-                       --enable-syslog \
-                       --disable-shadow \
-                       --disable-lastlog \
-                       --disable-utmp \
-                       --disable-utmpx \
-                       --disable-wtmp \
-                       --disable-wtmpx \
-                       --disable-loginfunc \
-                       --disable-pututline \
-                       --disable-pututxline \
-                       --disable-zlib \
-       );
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
@@ -98,23 +74,26 @@ define Build/Compile
 endef
        
 define Package/dropbear/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/dropbearmulti \
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearmulti \
                $(1)/usr/sbin/dropbear
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        ln -sf ../sbin/dropbear $(1)/usr/bin/scp
        ln -sf ../sbin/dropbear $(1)/usr/bin/ssh
        ln -sf ../sbin/dropbear $(1)/usr/bin/dbclient
        ln -sf ../sbin/dropbear $(1)/usr/bin/dropbearkey
-       install -d -m0755 $(1)/etc/config
-       install -m0755 ./files/dropbear.config $(1)/etc/config/dropbear
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/dropbear.init $(1)/etc/init.d/dropbear
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/dropbear.config $(1)/etc/config/dropbear
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/dropbear.init $(1)/etc/init.d/dropbear
+       $(INSTALL_DIR) $(1)/usr/lib/ipkg/info
+       echo /etc/dropbear/dropbear_rsa_host_key > $(1)/usr/lib/ipkg/info/dropbear.conffiles
+       echo /etc/dropbear/dropbear_dss_host_key >> $(1)/usr/lib/ipkg/info/dropbear.conffiles
 endef
 
 define Package/dropbearconvert/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/dropbearconvert \
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearconvert \
                $(1)/usr/bin/dropbearconvert
 endef