Keep firewall.user during sysupgrades
[openwrt/openwrt.git] / package / firewall / Makefile
index 40c82837fc62f90079533c6dbc0bfa4857e8d0d8..15237ff8f44b00fdd9be7ff83ab5cc20bfcb12b9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=11
+PKG_RELEASE:=23
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -18,12 +18,13 @@ define Package/firewall
   CATEGORY:=Base system
   URL:=http://openwrt.org/
   TITLE:=OpenWrt firewall
+  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   DEPENDS:=+iptables +iptables-mod-conntrack +iptables-mod-nat
   PKGARCH:=all
 endef
 
 define Package/firewall/description
uci based firewall for openwrt
UCI based firewall for OpenWrt
 endef
 
 define Build/Compile
@@ -32,6 +33,7 @@ endef
 
 define Package/firewall/conffiles
 /etc/config/firewall
+/etc/firewall.user
 endef
 
 define Package/firewall/install
@@ -49,6 +51,8 @@ define Package/firewall/install
        $(INSTALL_DATA) ./files/reflection.hotplug $(1)/etc/hotplug.d/firewall/10-nat-reflection
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/firewall.user $(1)/etc
+       $(INSTALL_DIR) $(1)/lib/upgrade/keep.d
+       $(INSTALL_DATA) ./files/firewall.upgrade $(1)/lib/upgrade/keep.d/firewall
 endef
 
 $(eval $(call BuildPackage,firewall))