use $(FPIC) in a few places where it matters
[openwrt/openwrt.git] / package / gmp / Makefile
index e813284800cad59a9a3c3bb00af1f26c6cb9498d..59a826bdb0d1abb61392ea6001f00937d0ad077a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=4.1.4
+PKG_VERSION:=4.2.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNU/gmp
-PKG_MD5SUM:=0aa7d3b3f5b5ec5951e7dddd6f65e891
+PKG_MD5SUM:=7ce52531644e6d12f16911b7e3151f3f
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,9 +22,15 @@ define Package/libgmp
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=GNU multiprecision arithmetic library
-  URL:=http://www.swox.com/gmp/
+  URL:=http://gmplib.org/
+endef
+
+define Package/libgmp/description
+       GMP is a free library for arbitrary precision arithmetic, operating on
+       signed integers, rational numbers, and floating point numbers.
 endef
 
+TARGET_CFLAGS += $(FPIC)
 CONFIGURE_VARS += CC="$(TARGET_CROSS)gcc"
 CONFIGURE_ARGS += \
        --enable-shared \
@@ -39,15 +45,10 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/gmp* $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgmp.{a,so*} $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/gmp* \
-               $(STAGING_DIR)/usr/lib/libgmp.{a,so*}
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/gmp* $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgmp.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libgmp/install