hostapd: select crda if mac80211 is selected
[openwrt/openwrt.git] / package / hostapd / Makefile
index 95b34141e7888a9ffb54606dfe5935251aabfb41..e6e23138645656562d0c95be73f2cd29c3782420 100644 (file)
@@ -54,7 +54,6 @@ DRIVER_MAKEOPTS= \
        CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \
        CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
        CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
-       CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch) \
        CONFIG_IEEE80211N=$(CONFIG_PACKAGE_kmod-ath9k)
 
 ifeq ($(LOCAL_TYPE),supplicant)
@@ -67,6 +66,8 @@ ifneq ($(LOCAL_TYPE),hostapd)
   ifdef CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
     TARGET_CFLAGS += -DNO_TIMESTAMP_CHECK
   endif
+  DRIVER_MAKEOPTS += \
+       CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
 endif
 
 define Package/hostapd/Default
@@ -74,7 +75,8 @@ define Package/hostapd/Default
   CATEGORY:=Network
   TITLE:=IEEE 802.1x Authenticator
   URL:=http://hostap.epitest.fi/
-  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny
+  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny +PACKAGE_kmod-mac80211:crda
+  MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 endef
 
 define Package/hostapd
@@ -114,7 +116,8 @@ define Package/wpad/Default
   CATEGORY:=Network
   TITLE:=IEEE 802.1x Authenticator/Supplicant
   URL:=http://hostap.epitest.fi/
-  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny
+  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny +PACKAGE_kmod-mac80211:crda
+  MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 endef
 
 define Package/wpad
@@ -143,7 +146,9 @@ define Package/wpa-supplicant
   CATEGORY:=Network
   TITLE:=WPA Supplicant
   URL:=http://hostap.epitest.fi/wpa_supplicant/
+  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +PACKAGE_kmod-mac80211:libnl-tiny +PACKAGE_kmod-mac80211:crda
   VARIANT:=supplicant-full
+  MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 endef
 
 define Package/wpa-supplicant/Description
@@ -170,6 +175,7 @@ define Package/wpa-cli
   CATEGORY:=Network
   DEPENDS:=wpa-supplicant
   TITLE:=WPA Supplicant command line interface
+  MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 endef
 
 define Package/wpa-cli/Description
@@ -217,8 +223,9 @@ endef
 
 define Build/Compile/wpad
        echo ` \
-               $(call Build/RunMake,hostapd,MULTICALL=1 dump_cflags); \
-               $(call Build/RunMake,wpa_supplicant,dump_cflags) | sed -e 's,$(TARGET_CFLAGS),,' \
+               $(call Build/RunMake,hostapd,-s MULTICALL=1 dump_cflags); \
+               $(call Build/RunMake,wpa_supplicant,-s dump_cflags) | \
+               sed -e 's,-n ,,g' -e 's,$(TARGET_CFLAGS),,' \
        ` > $(PKG_BUILD_DIR)/.cflags
        $(call Build/RunMake,hostapd, \
                CFLAGS="$$$$(cat $(PKG_BUILD_DIR)/.cflags)" \