upgrade iproute2 to 2.6.29-1 - includes support for the skbedit scheduler action
[openwrt/openwrt.git] / package / hotplug2 / Makefile
index c46da06e0a323c8645c6a224d0deff77ea41422c..df0a7500a8a518a0affc83ff6e89caeed8d2e6c8 100644 (file)
@@ -8,35 +8,43 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hotplug2
-PKG_VERSION:=0.9
+PKG_REV:=198
+PKG_VERSION:=$(PKG_REV)
 PKG_RELEASE:=3
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
-PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=hotplug2-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://svn.nomi.cz/svn/isteve/hotplug2 
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
+#PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
+#PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/hotplug2
   SECTION:=base
   CATEGORY:=Base system
-  VERSION:=0.9+r102-$(PKG_RELEASE)
-  TITLE:=Dynamic device management subsystem for embedded systems
+  VERSION:=1.0-beta-$(PKG_RELEASE)
+  TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
 endef
 
 define Package/hotplug2/description
  Hotplug2 is a trivial replacement of some of the UDev functionality
  in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
+ This is an implementation of Hotplug2-1.0-beta
 endef
 
-MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES -I."
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) $(FPIC) -DHAVE_RULES -I."
 
 define Package/hotplug2/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
+       $(INSTALL_DIR) $(1)/lib/hotplug2
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/workers/worker_fork.so $(1)/lib/hotplug2
 endef
 
 $(eval $(call BuildPackage,hotplug2))