netfilter/iptables: disable IMQ on 2.6.27
[openwrt/openwrt.git] / package / iptables / Makefile
index 9d6d8f842395fa72111c03e1212197259df62449..c62d9741a1164bcc795b57f573ed9084e51cb2f9 100644 (file)
@@ -15,6 +15,7 @@ ifeq ($(CONFIG_LINUX_2_4),y)
   PKG_VERSION:=1.3.8
   PKG_RELEASE:=3
   PKG_MD5SUM:=0a9209f928002e5eee9cdff8fef4d4b3
+  MAKE_TARGETS:=experimental install-experimental
 endif
 
 ifeq ($(CONFIG_LINUX_2_6),y)
@@ -55,20 +56,38 @@ define Package/iptables
 $(call Package/iptables/Default)
   TITLE:=IPv4 firewall administration tool
   MENU:=1
+  DEPENDS+= +kmod-ipt-core
 endef
 
-define Package/iptables/conffiles
-/etc/firewall.config
-/etc/firewall.user
+define Package/iptables/description
+ IPv4 firewall administration tool.
+ Includes support for:
+ - limit
+ - LOG
+ - mac
+ - multiport
+ - REJECT
+ - TCPMSS
 endef
 
 define Package/iptables-mod-conntrack
 $(call Package/iptables/Module, +kmod-ipt-conntrack)
-  TITLE:=connection tracking modules
+  TITLE:=Basic connection tracking extensions
 endef
 
 define Package/iptables-mod-conntrack/description
- iptables extensions for connection tracking.
+ Basic iptables extensions for connection tracking.
+ Includes:
+ - state
+endef
+
+define Package/iptables-mod-conntrack-extra
+$(call Package/iptables/Module, +kmod-ipt-conntrack-extra)
+  TITLE:=Extra connection tracking extensions
+endef
+
+define Package/iptables-mod-conntrack-extra/description
+ Extra iptables extensions for connection tracking.
  Includes:
  - libipt_conntrack
  - libipt_helper
@@ -77,7 +96,7 @@ endef
 
 define Package/iptables-mod-filter
 $(call Package/iptables/Module, +kmod-ipt-filter)
-  TITLE:=filter modules
+  TITLE:=Content inspection extensions
 endef
 
 define Package/iptables-mod-filter/description
@@ -88,7 +107,7 @@ define Package/iptables-mod-filter/description
 endef
 
 define Package/iptables-mod-imq
-$(call Package/iptables/Module, +kmod-ipt-imq @!LINUX_2_6_25)
+$(call Package/iptables/Module, +kmod-ipt-imq @!LINUX_2_6_27)
   TITLE:=IMQ support
 endef
 
@@ -100,11 +119,11 @@ endef
 
 define Package/iptables-mod-ipopt
 $(call Package/iptables/Module, +kmod-ipt-ipopt)
-  TITLE:=IP/Packet option modules
+  TITLE:=IP/Packet option extensions
 endef
 
 define Package/iptables-mod-ipopt/description
- iptables extensions for matching/changing IP packet options.\\\
+ iptables extensions for matching/changing IP packet options.
  Includes:
  - libipt_CLASSIFY
  - libipt_dscp/DSCP
@@ -121,7 +140,7 @@ endef
 
 define Package/iptables-mod-ipsec
 $(call Package/iptables/Module, +kmod-ipt-ipsec)
-  TITLE:=IPSec extensions
+  TITLE:=IPsec extensions
 endef
 
 define Package/iptables-mod-ipsec/description
@@ -134,13 +153,26 @@ endef
 
 define Package/iptables-mod-nat
 $(call Package/iptables/Module, +kmod-ipt-nat)
-  TITLE:=extra NAT targets
+  TITLE:=Basic NAT extensions
 endef
 
 define Package/iptables-mod-nat/description
- iptables extensions for different NAT targets.
+ iptables extensions for basic NAT targets.
  Includes:
- - libipt_REDIRECT
+ - MASQUERADE
+ - SNAT
+ - DNAT
+endef
+
+define Package/iptables-mod-nat-extra
+$(call Package/iptables/Module, +kmod-ipt-nat-extra)
+  TITLE:=Extra NAT extensions
+endef
+
+define Package/iptables-mod-nat-extra/description
+ iptables extensions for extra NAT targets.
+ Includes:
+ - REDIRECT
 endef
 
 define Package/iptables-mod-ulog
@@ -156,7 +188,7 @@ endef
 
 define Package/iptables-mod-iprange
 $(call Package/iptables/Module, +kmod-ipt-iprange)
-  TITLE:=ip range module
+  TITLE:=IP range extension
 endef
 
 define Package/iptables-mod-iprange/description
@@ -167,13 +199,12 @@ endef
 
 define Package/iptables-mod-extra
 $(call Package/iptables/Module, +kmod-ipt-extra)
-  TITLE:=other extra iptables extensions
+  TITLE:=Other extra iptables extensions
 endef
 
 define Package/iptables-mod-extra/description
  other extra iptables extensions.
  Includes:
- - libipt_limit
  - libipt_owner
  - libipt_physdev
  - libipt_pkttype
@@ -187,7 +218,7 @@ endef
 
 define Package/iptables-mod-ipset
 $(call Package/iptables/Module, +kmod-ipt-ipset)
-  TITLE:=ipset iptables extension
+  TITLE:=IPset extension
 endef
 
 define Package/iptables-utils
@@ -221,6 +252,8 @@ define Build/Configure
                clean
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -230,7 +263,7 @@ define Build/Compile
                KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                KBUILD_OUTPUT="$(LINUX_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all experimental install install-experimental
+               all install $(MAKE_TARGETS)
 endef
 
 define Build/InstallDev
@@ -246,13 +279,6 @@ define Build/InstallDev
 endef
 
 define Package/iptables/install
-       $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/firewall.config $(1)/etc/
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
-       $(INSTALL_BIN) ./files/firewall.user $(1)/etc/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) ./files/firewall.awk $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/iptables
@@ -305,6 +331,7 @@ L7_INSTALL:=\
 $(eval $(call BuildPackage,iptables))
 $(eval $(call BuildPackage,iptables-utils))
 $(eval $(call BuildPlugin,iptables-mod-conntrack,$(IPT_CONNTRACK-m)))
+$(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-extra,$(IPT_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipset,$(IPT_IPSET-m)))
 $(eval $(call BuildPlugin,iptables-mod-filter,$(IPT_FILTER-m),$(L7_INSTALL)))
@@ -312,6 +339,7 @@ $(eval $(call BuildPlugin,iptables-mod-imq,$(IPT_IMQ-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipopt,$(IPT_IPOPT-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipsec,$(IPT_IPSEC-m)))
 $(eval $(call BuildPlugin,iptables-mod-nat,$(IPT_NAT-m)))
+$(eval $(call BuildPlugin,iptables-mod-nat-extra,$(IPT_NAT_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
 $(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
 $(eval $(call BuildPackage,ip6tables))