comgt: add missing file (fixes #10301)
[openwrt/openwrt.git] / package / ixp4xx-microcode / Makefile
index f75b0aa395e3c97e9c609b4a26aae4d0c3f439ea..9ed912758b07e28f5749491f0094e7444a9bdc00 100644 (file)
@@ -9,13 +9,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ixp4xx-microcode
 PKG_VERSION:=2.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
-PKG_SOURCE:=IPL_ixp400NpeLibrary-2_4.zip
-PKG_SOURCE_URL:=http://downloadmirror.intel.com/12954/eng/
-PKG_MD5SUM:=9a6dc3846041b899edf9eff8a906fb11
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=IPL_ixp400NpeLibraryWithCrypto-2_4.zip
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
+PKG_MD5SUM:=dd5f6482e625ecb334469958bcd54b37
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -49,6 +47,7 @@ endef
 define Package/ixp4xx-microcode/install
        $(INSTALL_DIR) $(1)/lib/firmware
        $(INSTALL_DIR) $(1)/usr/share/doc
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/NPE-A $(1)/lib/firmware/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/NPE-B $(1)/lib/firmware/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/NPE-C $(1)/lib/firmware/
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/LICENSE.IPL $(1)/usr/share/doc/