ath10k-ct: Update DEPENDS and PROVIDES
[openwrt/openwrt.git] / package / kernel / ath10k-ct / Makefile
index 83d3a05bd8530c47af587c8c17f12432dead45dd..0e416aa8b5548c836a094b8070c92fd52c645e4d 100644 (file)
@@ -33,7 +33,8 @@ define KernelPackage/ath10k-ct
   FILES:=\
        $(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_pci.ko \
        $(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_core.ko
-  AUTOLOAD:=$(call AutoProbe,ath10k_pci)
+  AUTOLOAD:=$(call AutoProbe,mac80211 ath ath10k_pci)
+  PROVIDES:=kmod-ath10k
 endef
 
 NOSTDINC_FLAGS = \