ltq-vdsl: update to version 4.17.18.6
[openwrt/openwrt.git] / package / kernel / lantiq / ltq-vdsl / patches / 100-compat.patch
index e68a6f0ec38ba7fd0495c24db44e5f869dd76f58..a8ce61fa36c69c18e36536f3e0713f348beb147c 100644 (file)
@@ -1,14 +1,14 @@
 --- a/src/Makefile.in
 +++ b/src/Makefile.in
-@@ -63,7 +63,7 @@ POST_UNINSTALL = :
+@@ -117,7 +117,7 @@ POST_UNINSTALL = :
  
  # the headerfile of linux kernels 2.6.x contain to much arithmetic
  # with void pointers (which is allowed for gcc!)
 -@KERNEL_2_6_FALSE@am__append_6 = -Wpointer-arith
 +@KERNEL_2_6_FALSE@am__append_6 =
  subdir = src
- DIST_COMMON = $(drv_dsl_cpe_api_include_HEADERS) $(srcdir)/Makefile.am \
      $(srcdir)/Makefile.in
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/configure.in
 --- a/src/common/drv_dsl_cpe_os_linux.c
 +++ b/src/common/drv_dsl_cpe_os_linux.c
 @@ -11,6 +11,7 @@
@@ -19,7 +19,7 @@
  #include "drv_dsl_cpe_api.h"
  #include "drv_dsl_cpe_api_ioctl.h"
  
-@@ -238,24 +239,10 @@ static DSL_long_t DSL_DRV_Ioctls(DSL_DRV
+@@ -249,14 +250,7 @@ static DSL_long_t DSL_DRV_Ioctls(DSL_DRV
     }
  
  #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,36))
 +   pINode = file_inode(pFile);
  #endif
  
--   if (pINode == DSL_NULL)
--   {
--      bIsInKernel = DSL_TRUE;
--   }
--   else
--   {
-       bIsInKernel = DSL_FALSE;
--   }
-    if ( (_IOC_TYPE(nCommand) == DSL_IOC_MAGIC_CPE_API) ||
-         (_IOC_TYPE(nCommand) == DSL_IOC_MAGIC_CPE_API_G997) ||
-@@ -1102,6 +1089,9 @@ static void DSL_DRV_DebugInit(void)
-    return;
+    if (pINode == DSL_NULL)
+@@ -1203,6 +1197,9 @@ static void DSL_DRV_NlSendMsg(DSL_char_t
  }
+ #endif
  
 +static struct class *dsl_class;
 +static dev_t dsl_devt;
@@ -55,7 +45,7 @@
  /* Entry point of driver */
  int __init DSL_ModuleInit(void)
  {
-@@ -1140,6 +1130,10 @@ int __init DSL_ModuleInit(void)
+@@ -1241,6 +1238,10 @@ int __init DSL_ModuleInit(void)
  
     DSL_DRV_DevNodeInit();
  
@@ -66,7 +56,7 @@
     return 0;
  }
  
-@@ -1147,6 +1141,11 @@ void __exit DSL_ModuleCleanup(void)
+@@ -1248,6 +1249,11 @@ void __exit DSL_ModuleCleanup(void)
  {
     printk("Module will be unloaded"DSL_DRV_CRLF);
  
 +   dsl_class = NULL;
 +
     unregister_chrdev(nMajorNum, DRV_DSL_CPE_API_DEV_NAME);
+    
     DSL_DRV_Cleanup();
+--- a/src/device/drv_dsl_cpe_device_vrx.c
++++ b/src/device/drv_dsl_cpe_device_vrx.c
+@@ -5337,6 +5337,7 @@ DSL_Error_t DSL_DRV_DEV_HybridTypeGet(
+ #undef DSL_DBG_BLOCK
+ #define DSL_DBG_BLOCK DSL_DBG_NOTIFICATIONS
++#if 0
+ DSL_Error_t DSL_DRV_DEV_MeiTcLayerSignaling
+ (
+    DSL_Context_t *pContext,
+@@ -5384,6 +5385,15 @@ DSL_Error_t DSL_DRV_DEV_MeiTcLayerSignal
+    return nErrCode;
+ }
++#else
++DSL_Error_t DSL_DRV_DEV_MeiTcLayerSignaling
++(
++   DSL_Context_t *pContext,
++   DSL_TcLayerSelection_t nTcLayer)
++{
++   return DSL_SUCCESS;
++}
++#endif
+ DSL_Error_t DSL_DRV_DEV_MeiShowtimeSignaling
+ (