kernel: Build: Split kmod-regmap
[openwrt/openwrt.git] / package / kernel / linux / modules / can.mk
index ab7fcfa53a3fa20d719c3290cf292f909d12436d..b0d254511bb5f09d34d03df4149184e8e9305dae 100644 (file)
@@ -23,10 +23,10 @@ define KernelPackage/can
        CONFIG_PCH_CAN=n \
        CONFIG_CAN_GRCAN=n \
        CONFIG_CAN_CC770=n \
-       CONFIG_CAN_C_CAN=n \
        CONFIG_CAN_MSCAN=n \
        CONFIG_CAN_SJA1000=n \
        CONFIG_CAN_SOFTING=n \
+       CONFIG_CAN_XILINXCAN=n \
        CONFIG_NET_EMATCH_CANID=n \
        CONFIG_CAN_DEBUG_DEVICES=n
   FILES:=$(LINUX_DIR)/drivers/net/can/can-dev.ko \
@@ -47,22 +47,6 @@ define AddDepends/can
 endef
 
 
-define KernelPackage/can-raw
-  TITLE:=Raw CAN Protcol
-  KCONFIG:=CONFIG_CAN_RAW
-  FILES:=$(LINUX_DIR)/net/can/can-raw.ko
-  AUTOLOAD:=$(call AutoProbe,can-raw)
-  $(call AddDepends/can)
-endef
-
-define KernelPackage/can-raw/description
- The raw CAN protocol option offers access to the CAN bus via
- the BSD  socket API.
-endef
-
-$(eval $(call KernelPackage,can-raw))
-
-
 define KernelPackage/can-bcm
   TITLE:=Broadcast Manager CAN Protcol
   KCONFIG:=CONFIG_CAN_BCM
@@ -80,6 +64,74 @@ endef
 $(eval $(call KernelPackage,can-bcm))
 
 
+define KernelPackage/can-c-can
+  TITLE:=BOSCH C_CAN/D_CAN drivers
+  KCONFIG:=CONFIG_CAN_C_CAN
+  FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can.ko
+  AUTOLOAD:=$(call AutoProbe,c_can)
+  $(call AddDepends/can)
+endef
+
+define KernelPackage/can-c-can/description
+ This driver adds generic support for the C_CAN/D_CAN chips.
+endef
+
+$(eval $(call KernelPackage,can-c-can))
+
+
+define KernelPackage/can-c-can-pci
+  TITLE:=PCI Bus based BOSCH C_CAN/D_CAN driver
+  KCONFIG:=CONFIG_CAN_C_CAN_PCI
+  DEPENDS:=kmod-can-c-can @PCI_SUPPORT
+  FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_pci.ko
+  AUTOLOAD:=$(call AutoProbe,c_can_pci)
+  $(call AddDepends/can)
+endef
+
+define KernelPackage/can-c-can-pci/description
+ This driver adds support for the C_CAN/D_CAN chips connected
+ to the PCI bus.
+endef
+
+$(eval $(call KernelPackage,can-c-can-pci))
+
+
+define KernelPackage/can-c-can-platform
+  TITLE:=Platform Bus based BOSCH C_CAN/D_CAN driver
+  KCONFIG:=CONFIG_CAN_C_CAN_PLATFORM
+  DEPENDS:=kmod-can-c-can +!LINUX_3_18:kmod-regmap-core
+  FILES:=$(LINUX_DIR)/drivers/net/can/c_can/c_can_platform.ko
+  AUTOLOAD:=$(call AutoProbe,c_can_platform)
+  $(call AddDepends/can)
+endef
+
+define KernelPackage/can-c-can-platform/description
+ This driver adds support for the C_CAN/D_CAN chips connected
+ to the "platform bus" (Linux abstraction for directly to the
+ processor attached devices) which can be found on various
+ boards from ST Microelectronics (http://www.st.com) like the
+ SPEAr1310 and SPEAr320 evaluation boards & TI (www.ti.com)
+ boards like am335x, dm814x, dm813x and dm811x.
+endef
+
+$(eval $(call KernelPackage,can-c-can-platform))
+
+
+define KernelPackage/can-flexcan
+  TITLE:=Support for Freescale FLEXCAN based chips
+  KCONFIG:=CONFIG_CAN_FLEXCAN
+  FILES:=$(LINUX_DIR)/drivers/net/can/flexcan.ko
+  AUTOLOAD:=$(call AutoProbe,flexcan)
+  $(call AddDepends/can,@TARGET_imx6)
+endef
+
+define KernelPackage/can-flexcan/description
+ Freescale FLEXCAN CAN bus controller implementation.
+endef
+
+$(eval $(call KernelPackage,can-flexcan))
+
+
 define KernelPackage/can-gw
   TITLE:=CAN Gateway/Router
   KCONFIG:=CONFIG_CAN_GW
@@ -95,20 +147,20 @@ endef
 $(eval $(call KernelPackage,can-gw))
 
 
-define KernelPackage/can-vcan
-  TITLE:=Virtual Local CAN Interface (vcan)
-  KCONFIG:=CONFIG_CAN_VCAN
-  FILES:=$(LINUX_DIR)/drivers/net/can/vcan.ko
-  AUTOLOAD:=$(call AutoProbe,vcan)
+define KernelPackage/can-raw
+  TITLE:=Raw CAN Protcol
+  KCONFIG:=CONFIG_CAN_RAW
+  FILES:=$(LINUX_DIR)/net/can/can-raw.ko
+  AUTOLOAD:=$(call AutoProbe,can-raw)
   $(call AddDepends/can)
 endef
 
-define KernelPackage/can-vcan/description
Similar to the network loopback devices, vcan offers a
virtual local CAN interface.
+define KernelPackage/can-raw/description
The raw CAN protocol option offers access to the CAN bus via
the BSD  socket API.
 endef
 
-$(eval $(call KernelPackage,can-vcan))
+$(eval $(call KernelPackage,can-raw))
 
 
 define KernelPackage/can-slcan
@@ -128,19 +180,20 @@ endef
 $(eval $(call KernelPackage,can-slcan))
 
 
-define KernelPackage/can-flexcan
-  TITLE:=Support for Freescale FLEXCAN based chips
-  KCONFIG:=CONFIG_CAN_FLEXCAN
-  FILES:=$(LINUX_DIR)/drivers/net/can/flexcan.ko
-  AUTOLOAD:=$(call AutoProbe,flexcan)
-  $(call AddDepends/can,@TARGET_imx6)
+define KernelPackage/can-usb-8dev
+  TITLE:=8 devices USB2CAN interface
+  KCONFIG:=CONFIG_CAN_8DEV_USB
+  FILES:=$(LINUX_DIR)/drivers/net/can/usb/usb_8dev.ko
+  AUTOLOAD:=$(call AutoProbe,usb_8dev)
+  $(call AddDepends/can,+kmod-usb-core)
 endef
 
-define KernelPackage/can-flexcan/description
- Freescale FLEXCAN CAN bus controller implementation.
+define KernelPackage/can-usb-8dev/description
+ This driver supports the USB2CAN interface
+ from 8 devices (http://www.8devices.com).
 endef
 
-$(eval $(call KernelPackage,can-flexcan))
+$(eval $(call KernelPackage,can-usb-8dev))
 
 
 define KernelPackage/can-usb-ems
@@ -178,7 +231,9 @@ $(eval $(call KernelPackage,can-usb-esd))
 define KernelPackage/can-usb-kvaser
   TITLE:=Kvaser CAN/USB interface
   KCONFIG:=CONFIG_CAN_KVASER_USB
-  FILES:=$(LINUX_DIR)/drivers/net/can/usb/kvaser_usb.ko
+  FILES:= \
+       $(LINUX_DIR)/drivers/net/can/usb/kvaser_usb.ko@lt4.19 \
+       $(LINUX_DIR)/drivers/net/can/usb/kvaser_usb/kvaser_usb.ko@ge4.19
   AUTOLOAD:=$(call AutoProbe,kvaser_usb)
   $(call AddDepends/can,+kmod-usb-core)
 endef
@@ -207,17 +262,19 @@ endef
 $(eval $(call KernelPackage,can-usb-peak))
 
 
-define KernelPackage/can-usb-8dev
-  TITLE:=8 devices USB2CAN interface
-  KCONFIG:=CONFIG_CAN_8DEV_USB
-  FILES:=$(LINUX_DIR)/drivers/net/can/usb/usb_8dev.ko
-  AUTOLOAD:=$(call AutoProbe,usb_8dev)
-  $(call AddDepends/can,+kmod-usb-core)
+define KernelPackage/can-vcan
+  TITLE:=Virtual Local CAN Interface (vcan)
+  KCONFIG:=CONFIG_CAN_VCAN
+  FILES:=$(LINUX_DIR)/drivers/net/can/vcan.ko
+  AUTOLOAD:=$(call AutoProbe,vcan)
+  $(call AddDepends/can)
 endef
 
-define KernelPackage/can-usb-8dev/description
- This driver supports the USB2CAN interface
from 8 devices (http://www.8devices.com).
+define KernelPackage/can-vcan/description
+ Similar to the network loopback devices, vcan offers a
virtual local CAN interface.
 endef
 
-$(eval $(call KernelPackage,can-usb-8dev))
+$(eval $(call KernelPackage,can-vcan))
+
+