kernel: remove module checks for 3.15/3.16/3.17
[openwrt/openwrt.git] / package / kernel / linux / modules / crypto.mk
index 21e98f3f8e383897adddb087be9a4fcd1f9dc959..22c790d2ee838addabcdf1a876f4254b5af82082 100644 (file)
@@ -342,10 +342,8 @@ define KernelPackage/crypto-crc32c
   TITLE:=CRC32c CRC module
   DEPENDS:=+kmod-crypto-hash
   KCONFIG:=CONFIG_CRYPTO_CRC32C
-  FILES:= \
-       $(LINUX_DIR)/crypto/crc32c.ko@lt3.15 \
-       $(LINUX_DIR)/crypto/crc32c_generic.ko@ge3.15
-  AUTOLOAD:=$(call AutoLoad,04,crc32c@lt3.15 crc32c_generic@ge3.15,1)
+  FILES:=$(LINUX_DIR)/crypto/crc32c_generic.ko
+  AUTOLOAD:=$(call AutoLoad,04,crc32c_generic,1)
   $(call AddDepends/crypto)
 endef