netdevices.mk: add Sun Neptune 10Gbit Ethernet
[openwrt/openwrt.git] / package / kernel / linux / modules / crypto.mk
index efcdeafa99b88841a76dc49bd8b27a4d1b3a971c..fc2739811ab4b3cb1550d83f4507f0d826b89be4 100644 (file)
@@ -363,6 +363,17 @@ endef
 
 $(eval $(call KernelPackage,crypto-ecb))
 
+define KernelPackage/crypto-cts
+  TITLE:=Cipher Text Stealing CryptoAPI module
+  DEPENDS:=+kmod-crypto-manager
+  KCONFIG:=CONFIG_CRYPTO_CTS
+  FILES:=$(LINUX_DIR)/crypto/cts.ko
+  AUTOLOAD:=$(call AutoLoad,09,cts)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-cts))
+
 
 define KernelPackage/crypto-hmac
   TITLE:=HMAC digest CryptoAPI module