modules: install the newly introduced grace.ko in nfs-common in 3.18
[openwrt/openwrt.git] / package / kernel / linux / modules / fs.mk
index 5faaf3777c236bb28bb9b15e96f87d6139ba7cd1..243f368aee21026d8abaadb9c62a7957811fd6e2 100644 (file)
@@ -121,6 +121,21 @@ endef
 
 $(eval $(call KernelPackage,fs-configfs))
 
+define KernelPackage/fs-cramfs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=Compressed RAM/ROM filesystem support
+  DEPENDS:=+kmod-lib-zlib
+  KCONFIG:= \
+       CONFIG_CRAMFS
+  FILES:=$(LINUX_DIR)/fs/cramfs/cramfs.ko
+  AUTOLOAD:=$(call AutoLoad,30,cramfs)
+endef
+
+define KernelPackage/fs-cramfs/description
+ Kernel module for cramfs support
+endef
+
+$(eval $(call KernelPackage,fs-cramfs))
 
 define KernelPackage/fs-exportfs
   SUBMENU:=$(FS_MENU)
@@ -158,6 +173,26 @@ endef
 $(eval $(call KernelPackage,fs-ext4))
 
 
+define KernelPackage/fs-f2fs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=F2FS filesystem support
+  DEPENDS:=@!LINUX_3_3
+  KCONFIG:= \
+       CONFIG_F2FS_FS \
+       CONFIG_F2FS_STAT_FS=y \
+       CONFIG_F2FS_FS_XATTR=n \
+       CONFIG_F2FS_CHECK_FS=n
+  FILES:=$(LINUX_DIR)/fs/f2fs/f2fs.ko
+  AUTOLOAD:=$(call AutoLoad,30,f2fs,1)
+endef
+
+define KernelPackage/fs-f2fs/description
+ Kernel module for F2FS filesystem support
+endef
+
+$(eval $(call KernelPackage,fs-f2fs))
+
+
 define KernelPackage/fuse
   SUBMENU:=$(FS_MENU)
   TITLE:=FUSE (Filesystem in Userspace) support
@@ -257,7 +292,7 @@ $(eval $(call KernelPackage,fs-msdos))
 define KernelPackage/fs-nfs
   SUBMENU:=$(FS_MENU)
   TITLE:=NFS filesystem support
-  DEPENDS:=+kmod-fs-nfs-common
+  DEPENDS:=+kmod-fs-nfs-common +kmod-dnsresolver
   KCONFIG:= \
        CONFIG_NFS_FS \
        CONFIG_NFS_USE_LEGACY_DNS=n \
@@ -286,10 +321,18 @@ define KernelPackage/fs-nfs-common
   KCONFIG:= \
        CONFIG_LOCKD \
        CONFIG_SUNRPC
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.18.0)),1)
+  FILES:= \
+       $(LINUX_DIR)/fs/nfs_common/grace.ko \
+       $(LINUX_DIR)/fs/lockd/lockd.ko \
+       $(LINUX_DIR)/net/sunrpc/sunrpc.ko
+  AUTOLOAD:=$(call AutoLoad,30,grace sunrpc lockd)
+else
   FILES:= \
        $(LINUX_DIR)/fs/lockd/lockd.ko \
        $(LINUX_DIR)/net/sunrpc/sunrpc.ko
   AUTOLOAD:=$(call AutoLoad,30,sunrpc lockd)
+endif
 endef
 
 $(eval $(call KernelPackage,fs-nfs-common))