kernel: update kmod-* packaging and dependencies for linux 4.9
[openwrt/openwrt.git] / package / kernel / linux / modules / hwmon.mk
index b1f4744330ba2458ce695f82ac4a748d06c664e9..6223a37ab268888d6dcc28fbd7fba97539ab7332 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,6 @@ define KernelPackage/hwmon-core
        CONFIG_HWMON_DEBUG_CHIP=n
   FILES:= \
        $(LINUX_DIR)/drivers/hwmon/hwmon.ko
-  AUTOLOAD:=$(call AutoLoad,17,hwmon,1)
 endef
 
 define KernelPackage/hwmon-core/description
@@ -45,11 +44,30 @@ endef
 $(eval $(call KernelPackage,hwmon-vid))
 
 
+define KernelPackage/hwmon-adt7410
+  TITLE:=ADT7410 monitoring support
+  KCONFIG:= \
+       CONFIG_SENSORS_ADT7X10 \
+       CONFIG_SENSORS_ADT7410
+  FILES:= \
+       $(LINUX_DIR)/drivers/hwmon/adt7x10.ko \
+       $(LINUX_DIR)/drivers/hwmon/adt7410.ko
+  AUTOLOAD:=$(call AutoLoad,60,adt7x10 adt7410)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-adt7410/description
+ Kernel module for ADT7410/7420 I2C thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-adt7410))
+
+
 define KernelPackage/hwmon-adt7475
   TITLE:=ADT7473/7475/7476/7490 monitoring support
   KCONFIG:=CONFIG_SENSORS_ADT7475
   FILES:=$(LINUX_DIR)/drivers/hwmon/adt7475.ko
-  AUTOLOAD:=$(call AutoLoad,60,adt7475)
+  AUTOLOAD:=$(call AutoProbe,adt7475)
   $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid)
 endef
 
@@ -60,12 +78,27 @@ endef
 $(eval $(call KernelPackage,hwmon-adt7475))
 
 
+define KernelPackage/hwmon-ina209
+  TITLE:=INA209 monitoring support
+  KCONFIG:=CONFIG_SENSORS_INA209
+  FILES:=$(LINUX_DIR)/drivers/hwmon/ina209.ko
+  AUTOLOAD:=$(call AutoProbe,ina209)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-ina209/description
+ Kernel module for ina209 dc power monitor chips
+endef
+
+$(eval $(call KernelPackage,hwmon-ina209))
+
+
 define KernelPackage/hwmon-ina2xx
   TITLE:=INA2XX monitoring support
   KCONFIG:=CONFIG_SENSORS_INA2XX
   FILES:=$(LINUX_DIR)/drivers/hwmon/ina2xx.ko
-  AUTOLOAD:=$(call AutoLoad,60,ina2xx)
-  $(call AddDepends/hwmon,+kmod-i2c-core)
+  AUTOLOAD:=$(call AutoProbe,ina2xx)
+  $(call AddDepends/hwmon,+kmod-i2c-core +!LINUX_3_18:kmod-regmap)
 endef
 
 define KernelPackage/hwmon-ina2xx/description
@@ -75,12 +108,26 @@ endef
 $(eval $(call KernelPackage,hwmon-ina2xx))
 
 
+define KernelPackage/hwmon-it87
+  TITLE:=IT87 monitoring support
+  KCONFIG:=CONFIG_SENSORS_IT87
+  FILES:=$(LINUX_DIR)/drivers/hwmon/it87.ko
+  AUTOLOAD:=$(call AutoProbe,it87)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid +PACKAGE_kmod-thermal:kmod-thermal)
+endef
+
+define KernelPackage/hwmon-it87/description
+ Kernel module for it87 thermal and voltage monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-it87))
+
 define KernelPackage/hwmon-lm63
   TITLE:=LM63/64 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM63
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm63.ko
-  AUTOLOAD:=$(call AutoLoad,60,lm63)
-  $(call AddDepends/hwmon,+kmod-i2c-core)
+  AUTOLOAD:=$(call AutoProbe,lm63)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-regmap)
 endef
 
 define KernelPackage/hwmon-lm63/description
@@ -94,8 +141,8 @@ define KernelPackage/hwmon-lm75
   TITLE:=LM75 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM75
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.ko
-  AUTOLOAD:=$(call AutoLoad,60,lm75)
-  $(call AddDepends/hwmon,+kmod-i2c-core)
+  AUTOLOAD:=$(call AutoProbe,lm75)
+  $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal +kmod-regmap)
 endef
 
 define KernelPackage/hwmon-lm75/description
@@ -109,7 +156,7 @@ define KernelPackage/hwmon-lm77
   TITLE:=LM77 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM77
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.ko
-  AUTOLOAD:=$(call AutoLoad,60,lm77)
+  AUTOLOAD:=$(call AutoProbe,lm77)
   $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
@@ -124,7 +171,7 @@ define KernelPackage/hwmon-lm85
   TITLE:=LM85 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM85
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm85.ko
-  AUTOLOAD:=$(call AutoLoad,60,lm85)
+  AUTOLOAD:=$(call AutoProbe,lm85)
   $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid)
 endef
 
@@ -139,7 +186,7 @@ define KernelPackage/hwmon-lm90
   TITLE:=LM90 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM90
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm90.ko
-  AUTOLOAD:=$(call AutoLoad,60,lm90)
+  AUTOLOAD:=$(call AutoProbe,lm90)
   $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
@@ -153,7 +200,7 @@ define KernelPackage/hwmon-lm92
   TITLE:=LM92 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM92
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm92.ko
-  AUTOLOAD:=$(call AutoLoad,60,lm92)
+  AUTOLOAD:=$(call AutoProbe,lm92)
   $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
@@ -167,7 +214,7 @@ define KernelPackage/hwmon-lm95241
   TITLE:=LM95241 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM95241
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm95241.ko
-  AUTOLOAD:=$(call AutoLoad,60,lm95241)
+  AUTOLOAD:=$(call AutoProbe,lm95241)
   $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
@@ -177,11 +224,25 @@ endef
 
 $(eval $(call KernelPackage,hwmon-lm95241))
 
+define KernelPackage/hwmon-ltc4151
+  TITLE:=LTC4151 monitoring support
+  KCONFIG:=CONFIG_SENSORS_LTC4151
+  FILES:=$(LINUX_DIR)/drivers/hwmon/ltc4151.ko
+  AUTOLOAD:=$(call AutoProbe,ltc4151)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-ltc4151/description
+ Kernel module for Linear Technology LTC4151 current and voltage monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-ltc4151))
+
 define KernelPackage/hwmon-sht21
   TITLE:=Sensiron SHT21 and compat. monitoring support
   KCONFIG:=CONFIG_SENSORS_SHT21
   FILES:=$(LINUX_DIR)/drivers/hwmon/sht21.ko
-  AUTOLOAD:=$(call AutoLoad,60,sht21)
+  AUTOLOAD:=$(call AutoProbe,sht21)
   $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
@@ -191,11 +252,27 @@ endef
 
 $(eval $(call KernelPackage,hwmon-sht21))
 
+define KernelPackage/hwmon-sch5627
+  TITLE:=SMSC SCH5627 monitoring support
+  KCONFIG:=CONFIG_SENSORS_SCH5627
+  FILES:= \
+       $(LINUX_DIR)/drivers/hwmon/sch5627.ko \
+       $(LINUX_DIR)/drivers/hwmon/sch56xx-common.ko
+  AUTOLOAD:=$(call AutoProbe,sch5627)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-sch5627/description
+ SMSC SCH5627 Super I/O chips include complete hardware monitoring
+endef
+
+$(eval $(call KernelPackage,hwmon-sch5627))
+
 define KernelPackage/hwmon-pc87360
   TITLE:=PC87360 monitoring support
   KCONFIG:=CONFIG_SENSORS_PC87360
   FILES:=$(LINUX_DIR)/drivers/hwmon/pc87360.ko
-  AUTOLOAD:=$(call AutoLoad,50,pc87360)
+  AUTOLOAD:=$(call AutoProbe,pc87360)
   $(call AddDepends/hwmon,@TARGET_x86 +kmod-hwmon-vid)
 endef
 
@@ -211,26 +288,117 @@ define KernelPackage/hwmon-w83627hf
   KCONFIG:=CONFIG_SENSORS_W83627HF
   FILES:=$(LINUX_DIR)/drivers/hwmon/w83627hf.ko
   AUTOLOAD:=$(call AutoLoad,50,w83627hf)
-$(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86 +kmod-hwmon-vid)
+  $(call AddDepends/hwmon,@TARGET_x86 +kmod-hwmon-vid)
 endef
 
-define KernelPacakge/hwmon-w83627hf/description
+define KernelPackage/hwmon-w83627hf/description
   Kernel module for the Winbond W83627HF chips.
 endef
 
 $(eval $(call KernelPackage,hwmon-w83627hf))
 
 
-define KernelPackage/hwmon-gsc
-  TITLE:=Gateworks GSC monitoring support
-  KCONFIG:=CONFIG_SENSORS_GSC
-  FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
-  AUTOLOAD:=$(call AutoLoad,50,gsc)
-$(call AddDepends/hwmon)
+define KernelPackage/hwmon-w83793
+  TITLE:=Winbond W83793G/R monitoring support
+  KCONFIG:=CONFIG_SENSORS_W83793
+  FILES:=$(LINUX_DIR)/drivers/hwmon/w83793.ko
+  AUTOLOAD:=$(call AutoProbe,w83793)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid)
+endef
+
+define KernelPackage/hwmon-w83793/description
+  Kernel module for the Winbond W83793G and W83793R chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-w83793))
+
+
+define KernelPackage/hwmon-tmp102
+  TITLE:=Texas Instruments TMP102 monitoring support
+  KCONFIG:=CONFIG_SENSORS_TMP102
+  FILES:=$(LINUX_DIR)/drivers/hwmon/tmp102.ko
+  AUTOLOAD:=$(call AutoProbe,tmp102)
+  $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal +kmod-regmap)
+endef
+
+define KernelPackage/hwmon-tmp102/description
+ Kernel module for Texas Instruments TMP102 temperature sensors chip
+endef
+
+$(eval $(call KernelPackage,hwmon-tmp102))
+
+
+define KernelPackage/hwmon-tmp103
+  TITLE:=Texas Instruments TMP103 monitoring support
+  KCONFIG:=CONFIG_SENSORS_TMP103
+  FILES:=$(LINUX_DIR)/drivers/hwmon/tmp103.ko
+  AUTOLOAD:=$(call AutoProbe,tmp103)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-regmap)
+endef
+
+define KernelPackage/hwmon-tmp103/description
+ Kernel module for Texas Instruments TMP103 temperature sensors chip
+endef
+
+$(eval $(call KernelPackage,hwmon-tmp103))
+
+
+define KernelPackage/hwmon-tmp421
+  TITLE:=TI TMP421 and compatible monitoring support
+  KCONFIG:=CONFIG_SENSORS_TMP421
+  FILES:=$(LINUX_DIR)/drivers/hwmon/tmp421.ko
+  AUTOLOAD:=$(call AutoLoad,60,tmp421)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-tmp421/description
+  Kernel module for the Texas Instruments TMP421 and compatible chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-tmp421))
+
+
+define KernelPackage/hwmon-gpiofan
+  TITLE:=Generic GPIO FAN support
+  KCONFIG:=CONFIG_SENSORS_GPIO_FAN
+  FILES:=$(LINUX_DIR)/drivers/hwmon/gpio-fan.ko
+  AUTOLOAD:=$(call AutoLoad,60,gpio-fan)
+  $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal)
+endef
+
+define KernelPackage/hwmon-gpiofan/description
+  Kernel module for GPIO controlled FANs
+endef
+
+$(eval $(call KernelPackage,hwmon-gpiofan))
+
+
+define KernelPackage/hwmon-pwmfan
+  TITLE:=Generic PWM FAN support
+  KCONFIG:=CONFIG_SENSORS_PWM_FAN
+  FILES:=$(LINUX_DIR)/drivers/hwmon/pwm-fan.ko
+  AUTOLOAD:=$(call AutoLoad,60,pwm-fan)
+  $(call AddDepends/hwmon, +PACKAGE_kmod-thermal:kmod-thermal)
+endef
+
+define KernelPackage/hwmon-pwmfan/description
+  Kernel module for PWM controlled FANs
+endef
+
+$(eval $(call KernelPackage,hwmon-pwmfan))
+
+
+define KernelPackage/hwmon-k10temp
+  TITLE:=AMD Family 10h+ temperature sensor
+  KCONFIG:=CONFIG_SENSORS_K10TEMP
+  FILES:=$(LINUX_DIR)/drivers/hwmon/k10temp.ko
+  AUTOLOAD:=$(call AutoLoad,60,k10temp)
+  $(call AddDepends/hwmon,@PCI_SUPPORT @TARGET_x86)
 endef
 
-define KernelPacakge/hwmon-gsc/description
-  Kernel module for the Gateworks System Controller chips.
+define KernelPackage/hwmon-k10temp/description
+  Thermal sensor support for AMD 10h, 11h, 12h (Llano), 14h (Brazos),
+  15h (Bulldozer/Trinity/Kaveri) and 16h (Kabini/Mullins) CPUs
 endef
 
-$(eval $(call KernelPackage,hwmon-gsc))
+$(eval $(call KernelPackage,hwmon-k10temp))