kernel: netconsole: add network console logging support
[openwrt/openwrt.git] / package / kernel / linux / modules / netsupport.mk
index d8074d27b6e626b60435e96fb80fed15929a71c9..53e21c0e9f72f0f5b9af03e7295584425bc3a7d6 100644 (file)
@@ -1437,3 +1437,19 @@ define KernelPackage/wireguard/description
 endef
 
 $(eval $(call KernelPackage,wireguard))
+
+
+define KernelPackage/netconsole
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=Network console logging support
+  KCONFIG:=CONFIG_NETCONSOLE \
+         CONFIG_NETCONSOLE_DYNAMIC=n
+  FILES:=$(LINUX_DIR)/drivers/net/netconsole.ko
+  AUTOLOAD:=$(call AutoProbe,netconsole)
+endef
+
+define KernelPackage/netconsole/description
+  Network console logging support.
+endef
+
+$(eval $(call KernelPackage,netconsole))