kernel/modules: add kmod-fou6 package
[openwrt/openwrt.git] / package / kernel / linux / modules / netsupport.mk
index 050541488c9b465a700f55eb5bb388e12b8c8317..f475b618d54e49c0afcc4742afe3a63486682476 100644 (file)
@@ -457,6 +457,27 @@ endef
 $(eval $(call KernelPackage,fou))
 
 
+define KernelPackage/fou6
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=FOU and GUE decapsulation over IPv6
+  DEPENDS:= @IPV6 \
+       +kmod-fou \
+       +kmod-ip6-tunnel
+  KCONFIG:= \
+       CONFIG_IPV6_FOU \
+       CONFIG_IPV6_FOU_TUNNEL
+  FILES:=$(LINUX_DIR)/net/ipv6/fou6.ko
+  AUTOLOAD:=$(call AutoProbe,fou6)
+endef
+
+define KernelPackage/fou6/description
+ Kernel module for FOU (Foo over UDP) and GUE (Generic UDP Encapsulation) tunnelling over IPv6.
+ Requires Kernel 3.18 or newer.
+endef
+
+$(eval $(call KernelPackage,fou6))
+
+
 define KernelPackage/ip6-tunnel
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IP-in-IPv6 tunnelling