kernel: remove gpio-pwm kmod definition
[openwrt/openwrt.git] / package / kernel / linux / modules / other.mk
index ce22819887ad24cbbdd0a7b6d9149acf33c8933b..5d1c2fb3486f7195441867569d974185f098ce37 100644 (file)
@@ -509,22 +509,6 @@ endef
 $(eval $(call KernelPackage,pwm))
 
 
-define KernelPackage/pwm-gpio
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=PWM over GPIO
-  DEPENDS:=+kmod-pwm
-  KCONFIG:=CONFIG_GPIO_PWM
-  FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.ko
-  AUTOLOAD:=$(call AutoProbe,gpio-pwm)
-endef
-
-define KernelPackage/pwm-gpio/description
- Kernel module to models a single-channel PWM device using a timer and a GPIO pin
-endef
-
-$(eval $(call KernelPackage,pwm-gpio))
-
-
 define KernelPackage/rtc-ds1307
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support