Revert "kernel: remove long obsolete gpio spi controller driver patch"
[openwrt/openwrt.git] / package / kernel / linux / modules / spi.mk
index b2999a84f5be2ac26d72410683e17f1a99e4be71..b16e26ef04279ad4235285b5636576e1bf2582b3 100644 (file)
@@ -43,6 +43,22 @@ endef
 $(eval $(call KernelPackage,spi-bitbang))
 
 
+define KernelPackage/spi-gpio-old
+  SUBMENU:=$(SPI_MENU)
+  TITLE:=Old GPIO based bitbanging SPI controller (DEPRECATED)
+  DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
+  KCONFIG:=CONFIG_SPI_GPIO_OLD
+  FILES:=$(LINUX_DIR)/drivers/spi/spi_gpio_old.ko
+  AUTOLOAD:=$(call AutoProbe,spi_gpio_old)
+endef
+
+define KernelPackage/spi-gpio-old/description
+ This package contains the GPIO based bitbanging SPI controller driver
+endef
+
+$(eval $(call KernelPackage,spi-gpio-old))
+
+
 define KernelPackage/spi-gpio
   SUBMENU:=$(SPI_MENU)
   TITLE:=GPIO-based bitbanging SPI Master