kernel: add backlight kernel module support
[openwrt/openwrt.git] / package / kernel / linux / modules / video.mk
index 3cbe69d5aa0240aec4b6067f15dda3588bda844d..61d7d88497b336910c3cd1882840515abc40e1de 100644 (file)
@@ -8,13 +8,53 @@
 
 VIDEO_MENU:=Video Support
 
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.7.0)),1)
 V4L2_DIR=v4l2-core
 V4L2_USB_DIR=usb
-else
-V4L2_DIR=video
-V4L2_USB_DIR=video
-endif
+
+#
+# Video Display
+#
+
+define KernelPackage/backlight
+       SUBMENU:=$(VIDEO_MENU)
+       TITLE:=Backlight support
+       KCONFIG:=CONFIG_BACKLIGHT_CLASS_DEVICE=m \
+               CONFIG_BACKLIGHT_LCD_SUPPORT=y \
+               CONFIG_LCD_CLASS_DEVICE=n \
+               CONFIG_BACKLIGHT_PWM=n \
+               CONFIG_BACKLIGHT_GENERIC=n \
+               CONFIG_BACKLIGHT_ADP8860=n \
+               CONFIG_BACKLIGHT_ADP8870=n \
+               CONFIG_BACKLIGHT_PM8941_WLED=n
+       FILES:=$(LINUX_DIR)/drivers/video/backlight/backlight.ko
+       AUTOLOAD:=$(call AutoProbe,video backlight)
+endef
+
+define KernelPackage/backlight/description
+       Kernel module for Backlight support.
+endef
+
+$(eval $(call KernelPackage,backlight))
+
+define AddDepends/backlight
+       SUBMENU:=$(VIDEO_MENU)
+       DEPENDS+=kmod-backlight $(1)
+endef
+
+define KernelPackage/backlight-pwm
+       TITLE:=PWM Backlight support
+       DEPENDS:=+kmod-pwm
+       KCONFIG:=CONFIG_BACKLIGHT_PWM=m
+       FILES:=$(LINUX_DIR)/drivers/video/backlight/pwm_bl.ko
+       AUTOLOAD:=$(call AutoProbe,video pwm_bl)
+       $(call AddDepends/backlight)
+endef
+
+define KernelPackage/backlight/backlight-pwm
+       Kernel module for PWM based Backlight support.
+endef
+
+$(eval $(call KernelPackage,backlight-pwm))
 
 
 define KernelPackage/fb
@@ -22,12 +62,12 @@ define KernelPackage/fb
   TITLE:=Framebuffer support
   DEPENDS:=@DISPLAY_SUPPORT
   KCONFIG:=CONFIG_FB
-  FILES:=$(LINUX_DIR)/drivers/video/fb.ko
+  FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/fb.ko
   AUTOLOAD:=$(call AutoLoad,06,fb)
 endef
 
 define KernelPackage/fb/description
 Kernel support for framebuffers
+ Kernel support for framebuffers
 endef
 
 define KernelPackage/fb/x86
@@ -42,12 +82,12 @@ define KernelPackage/fb-cfb-fillrect
   TITLE:=Framebuffer software rectangle filling support
   DEPENDS:=+kmod-fb
   KCONFIG:=CONFIG_FB_CFB_FILLRECT
-  FILES:=$(LINUX_DIR)/drivers/video/cfbfillrect.ko
+  FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/cfbfillrect.ko
   AUTOLOAD:=$(call AutoLoad,07,cfbfillrect)
 endef
 
 define KernelPackage/fb-cfb-fillrect/description
 Kernel support for software rectangle filling
+ Kernel support for software rectangle filling
 endef
 
 $(eval $(call KernelPackage,fb-cfb-fillrect))
@@ -58,12 +98,12 @@ define KernelPackage/fb-cfb-copyarea
   TITLE:=Framebuffer software copy area support
   DEPENDS:=+kmod-fb
   KCONFIG:=CONFIG_FB_CFB_COPYAREA
-  FILES:=$(LINUX_DIR)/drivers/video/cfbcopyarea.ko
+  FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/cfbcopyarea.ko
   AUTOLOAD:=$(call AutoLoad,07,cfbcopyarea)
 endef
 
 define KernelPackage/fb-cfb-copyarea/description
 Kernel support for software copy area
+ Kernel support for software copy area
 endef
 
 $(eval $(call KernelPackage,fb-cfb-copyarea))
@@ -73,12 +113,12 @@ define KernelPackage/fb-cfb-imgblt
   TITLE:=Framebuffer software image blit support
   DEPENDS:=+kmod-fb
   KCONFIG:=CONFIG_FB_CFB_IMAGEBLIT
-  FILES:=$(LINUX_DIR)/drivers/video/cfbimgblt.ko
+  FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/cfbimgblt.ko
   AUTOLOAD:=$(call AutoLoad,07,cfbimgblt)
 endef
 
 define KernelPackage/fb-cfb-imgblt/description
 Kernel support for software image blitting
+ Kernel support for software image blitting
 endef
 
 $(eval $(call KernelPackage,fb-cfb-imgblt))
@@ -127,15 +167,17 @@ endef
 
 define KernelPackage/video-videobuf2
   TITLE:=videobuf2 lib
+  DEPENDS:=+kmod-dma-buf
   KCONFIG:= \
        CONFIG_VIDEOBUF2_CORE \
        CONFIG_VIDEOBUF2_MEMOPS \
        CONFIG_VIDEOBUF2_VMALLOC
   FILES:= \
        $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videobuf2-core.ko \
+       $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videobuf2-v4l2.ko@ge4.4 \
        $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videobuf2-memops.ko \
        $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videobuf2-vmalloc.ko
-  AUTOLOAD:=$(call AutoLoad,65,videobuf2-core videobuf2-memops videobuf2-vmalloc)
+  AUTOLOAD:=$(call AutoLoad,65,videobuf2-core videobuf-v4l2@ge4.4 videobuf2-memops videobuf2-vmalloc)
   $(call AddDepends/video)
 endef
 
@@ -151,35 +193,17 @@ define KernelPackage/video-cpia2
   DEPENDS:=@USB_SUPPORT +kmod-usb-core
   KCONFIG:=CONFIG_VIDEO_CPIA2
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/cpia2/cpia2.ko
-  AUTOLOAD:=$(call AutoLoad,70,cpia2)
+  AUTOLOAD:=$(call AutoProbe,cpia2)
   $(call AddDepends/camera)
 endef
 
 define KernelPackage/video-cpia2/description
- Kernel modules for supporting CPIA2 USB based cameras.
+ Kernel modules for supporting CPIA2 USB based cameras
 endef
 
 $(eval $(call KernelPackage,video-cpia2))
 
 
-define KernelPackage/video-sn9c102
-  TITLE:=SN9C102 Camera Chip support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core
-  KCONFIG:=CONFIG_USB_SN9C102
-  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/sn9c102/sn9c102.ko
-  AUTOLOAD:=$(call AutoLoad,70,gspca_sn9c20x)
-  $(call AddDepends/camera)
-endef
-
-
-define KernelPackage/video-sn9c102/description
- Kernel modules for supporting SN9C102
- camera chips.
-endef
-
-$(eval $(call KernelPackage,video-sn9c102))
-
-
 define KernelPackage/video-pwc
   TITLE:=Philips USB webcam support
   DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2
@@ -187,30 +211,28 @@ define KernelPackage/video-pwc
        CONFIG_USB_PWC \
        CONFIG_USB_PWC_DEBUG=n
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/pwc/pwc.ko
-  AUTOLOAD:=$(call AutoLoad,70,pwc)
+  AUTOLOAD:=$(call AutoProbe,pwc)
   $(call AddDepends/camera)
 endef
 
-
 define KernelPackage/video-pwc/description
- Kernel modules for supporting Philips USB based cameras.
+ Kernel modules for supporting Philips USB based cameras
 endef
 
 $(eval $(call KernelPackage,video-pwc))
 
+
 define KernelPackage/video-uvc
   TITLE:=USB Video Class (UVC) support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2 +kmod-input-core
   KCONFIG:= CONFIG_USB_VIDEO_CLASS
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/uvc/uvcvideo.ko
-  AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
+  AUTOLOAD:=$(call AutoProbe,uvcvideo)
   $(call AddDepends/camera)
-  $(call AddDepends/input)
 endef
 
-
 define KernelPackage/video-uvc/description
- Kernel modules for supporting USB Video Class (UVC) devices.
+ Kernel modules for supporting USB Video Class (UVC) devices
 endef
 
 $(eval $(call KernelPackage,video-uvc))
@@ -222,7 +244,7 @@ define KernelPackage/video-gspca-core
   DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-input-core
   KCONFIG:=CONFIG_USB_GSPCA
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_main.ko
-  AUTOLOAD:=$(call AutoLoad,70,gspca_main)
+  AUTOLOAD:=$(call AutoProbe,gspca_main)
   $(call AddDepends/camera)
 endef
 
@@ -244,12 +266,12 @@ define KernelPackage/video-gspca-conex
   TITLE:=conex webcam support
   KCONFIG:=CONFIG_USB_GSPCA_CONEX
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_conex.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_conex)
+  AUTOLOAD:=$(call AutoProbe,gspca_conex)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-conex/description
- The Conexant Camera Driver (conex) kernel module.
+ The Conexant Camera Driver (conex) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-conex))
@@ -259,12 +281,12 @@ define KernelPackage/video-gspca-etoms
   TITLE:=etoms webcam support
   KCONFIG:=CONFIG_USB_GSPCA_ETOMS
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_etoms.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_etoms)
+  AUTOLOAD:=$(call AutoProbe,gspca_etoms)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-etoms/description
- The Etoms USB Camera Driver (etoms) kernel module.
+ The Etoms USB Camera Driver (etoms) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-etoms))
@@ -274,12 +296,12 @@ define KernelPackage/video-gspca-finepix
   TITLE:=finepix webcam support
   KCONFIG:=CONFIG_USB_GSPCA_FINEPIX
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_finepix.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_finepix)
+  AUTOLOAD:=$(call AutoProbe,gspca_finepix)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-finepix/description
- The Fujifilm FinePix USB V4L2 driver (finepix) kernel module.
+ The Fujifilm FinePix USB V4L2 driver (finepix) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-finepix))
@@ -289,12 +311,12 @@ define KernelPackage/video-gspca-mars
   TITLE:=mars webcam support
   KCONFIG:=CONFIG_USB_GSPCA_MARS
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_mars.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_mars)
+  AUTOLOAD:=$(call AutoProbe,gspca_mars)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-mars/description
- The Mars USB Camera Driver (mars) kernel module.
+ The Mars USB Camera Driver (mars) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-mars))
@@ -304,12 +326,12 @@ define KernelPackage/video-gspca-mr97310a
   TITLE:=mr97310a webcam support
   KCONFIG:=CONFIG_USB_GSPCA_MR97310A
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_mr97310a.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_mr97310a)
+  AUTOLOAD:=$(call AutoProbe,gspca_mr97310a)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-mr97310a/description
- The Mars-Semi MR97310A USB Camera Driver (mr97310a) kernel module.
+ The Mars-Semi MR97310A USB Camera Driver (mr97310a) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-mr97310a))
@@ -319,12 +341,12 @@ define KernelPackage/video-gspca-ov519
   TITLE:=ov519 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_OV519
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_ov519.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_ov519)
+  AUTOLOAD:=$(call AutoProbe,gspca_ov519)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-ov519/description
- The OV519 USB Camera Driver (ov519) kernel module.
+ The OV519 USB Camera Driver (ov519) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-ov519))
@@ -334,12 +356,12 @@ define KernelPackage/video-gspca-ov534
   TITLE:=ov534 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_OV534
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_ov534.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_ov534)
+  AUTOLOAD:=$(call AutoProbe,gspca_ov534)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-ov534/description
- The OV534 USB Camera Driver (ov534) kernel module.
+ The OV534 USB Camera Driver (ov534) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-ov534))
@@ -349,12 +371,12 @@ define KernelPackage/video-gspca-ov534-9
   TITLE:=ov534-9 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_OV534_9
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_ov534_9.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_ov534_9)
+  AUTOLOAD:=$(call AutoProbe,gspca_ov534_9)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-ov534-9/description
- The OV534-9 USB Camera Driver (ov534_9) kernel module.
+ The OV534-9 USB Camera Driver (ov534_9) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-ov534-9))
@@ -364,12 +386,12 @@ define KernelPackage/video-gspca-pac207
   TITLE:=pac207 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_PAC207
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_pac207.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_pac207)
+  AUTOLOAD:=$(call AutoProbe,gspca_pac207)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-pac207/description
- The Pixart PAC207 USB Camera Driver (pac207) kernel module.
+ The Pixart PAC207 USB Camera Driver (pac207) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-pac207))
@@ -379,12 +401,12 @@ define KernelPackage/video-gspca-pac7311
   TITLE:=pac7311 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_PAC7311
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_pac7311.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_pac7311)
+  AUTOLOAD:=$(call AutoProbe,gspca_pac7311)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-pac7311/description
- The Pixart PAC7311 USB Camera Driver (pac7311) kernel module.
+ The Pixart PAC7311 USB Camera Driver (pac7311) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-pac7311))
@@ -394,12 +416,12 @@ define KernelPackage/video-gspca-se401
   TITLE:=se401 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SE401
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_se401.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_se401)
+  AUTOLOAD:=$(call AutoProbe,gspca_se401)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-se401/description
- The SE401 USB Camera Driver kernel module.
+ The SE401 USB Camera Driver kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-se401))
@@ -409,12 +431,12 @@ define KernelPackage/video-gspca-sn9c20x
   TITLE:=sn9c20x webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SN9C20X
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sn9c20x.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_sn9c20x)
+  AUTOLOAD:=$(call AutoProbe,gspca_sn9c20x)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sn9c20x/description
- The SN9C20X USB Camera Driver (sn9c20x) kernel module.
+ The SN9C20X USB Camera Driver (sn9c20x) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-sn9c20x))
@@ -424,12 +446,12 @@ define KernelPackage/video-gspca-sonixb
   TITLE:=sonixb webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SONIXB
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sonixb.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_sonixb)
+  AUTOLOAD:=$(call AutoProbe,gspca_sonixb)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sonixb/description
- The SONIX Bayer USB Camera Driver (sonixb) kernel module.
+ The SONIX Bayer USB Camera Driver (sonixb) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-sonixb))
@@ -439,12 +461,12 @@ define KernelPackage/video-gspca-sonixj
   TITLE:=sonixj webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SONIXJ
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sonixj.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_sonixj)
+  AUTOLOAD:=$(call AutoProbe,gspca_sonixj)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sonixj/description
- The SONIX JPEG USB Camera Driver (sonixj) kernel module.
+ The SONIX JPEG USB Camera Driver (sonixj) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-sonixj))
@@ -454,12 +476,12 @@ define KernelPackage/video-gspca-spca500
   TITLE:=spca500 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA500
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca500.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_spca500)
+  AUTOLOAD:=$(call AutoProbe,gspca_spca500)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca500/description
- The SPCA500 USB Camera Driver (spca500) kernel module.
+ The SPCA500 USB Camera Driver (spca500) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-spca500))
@@ -469,12 +491,12 @@ define KernelPackage/video-gspca-spca501
   TITLE:=spca501 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA501
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca501.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_spca501)
+  AUTOLOAD:=$(call AutoProbe,gspca_spca501)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca501/description
- The SPCA501 USB Camera Driver (spca501) kernel module.
+ The SPCA501 USB Camera Driver (spca501) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-spca501))
@@ -484,12 +506,12 @@ define KernelPackage/video-gspca-spca505
   TITLE:=spca505 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA505
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca505.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_spca505)
+  AUTOLOAD:=$(call AutoProbe,gspca_spca505)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca505/description
- The SPCA505 USB Camera Driver (spca505) kernel module.
+ The SPCA505 USB Camera Driver (spca505) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-spca505))
@@ -499,12 +521,12 @@ define KernelPackage/video-gspca-spca506
   TITLE:=spca506 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA506
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca506.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_spca506)
+  AUTOLOAD:=$(call AutoProbe,gspca_spca506)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca506/description
- The SPCA506 USB Camera Driver (spca506) kernel module.
+ The SPCA506 USB Camera Driver (spca506) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-spca506))
@@ -514,12 +536,12 @@ define KernelPackage/video-gspca-spca508
   TITLE:=spca508 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA508
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca508.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_spca508)
+  AUTOLOAD:=$(call AutoProbe,gspca_spca508)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca508/description
- The SPCA508 USB Camera Driver (spca508) kernel module.
+ The SPCA508 USB Camera Driver (spca508) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-spca508))
@@ -529,12 +551,12 @@ define KernelPackage/video-gspca-spca561
   TITLE:=spca561 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA561
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca561.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_spca561)
+  AUTOLOAD:=$(call AutoProbe,gspca_spca561)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca561/description
- The SPCA561 USB Camera Driver (spca561) kernel module.
+ The SPCA561 USB Camera Driver (spca561) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-spca561))
@@ -544,12 +566,12 @@ define KernelPackage/video-gspca-sq905
   TITLE:=sq905 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SQ905
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sq905.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_sq905)
+  AUTOLOAD:=$(call AutoProbe,gspca_sq905)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sq905/description
- The SQ Technologies SQ905 based USB Camera Driver (sq905) kernel module.
+ The SQ Technologies SQ905 based USB Camera Driver (sq905) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-sq905))
@@ -559,12 +581,12 @@ define KernelPackage/video-gspca-sq905c
   TITLE:=sq905c webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SQ905C
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sq905c.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_sq905c)
+  AUTOLOAD:=$(call AutoProbe,gspca_sq905c)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sq905c/description
- The SQ Technologies SQ905C based USB Camera Driver (sq905c) kernel module.
+ The SQ Technologies SQ905C based USB Camera Driver (sq905c) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-sq905c))
@@ -574,12 +596,12 @@ define KernelPackage/video-gspca-stk014
   TITLE:=stk014 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_STK014
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_stk014.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_stk014)
+  AUTOLOAD:=$(call AutoProbe,gspca_stk014)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-stk014/description
- The Syntek DV4000 (STK014) USB Camera Driver (stk014) kernel module.
+ The Syntek DV4000 (STK014) USB Camera Driver (stk014) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-stk014))
@@ -589,12 +611,12 @@ define KernelPackage/video-gspca-sunplus
   TITLE:=sunplus webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SUNPLUS
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sunplus.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_sunplus)
+  AUTOLOAD:=$(call AutoProbe,gspca_sunplus)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sunplus/description
- The SUNPLUS USB Camera Driver (sunplus) kernel module.
+ The SUNPLUS USB Camera Driver (sunplus) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-sunplus))
@@ -604,12 +626,12 @@ define KernelPackage/video-gspca-t613
   TITLE:=t613 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_T613
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_t613.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_t613)
+  AUTOLOAD:=$(call AutoProbe,gspca_t613)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-t613/description
- The T613 (JPEG Compliance) USB Camera Driver (t613) kernel module.
+ The T613 (JPEG Compliance) USB Camera Driver (t613) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-t613))
@@ -619,12 +641,12 @@ define KernelPackage/video-gspca-tv8532
   TITLE:=tv8532 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_TV8532
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_tv8532.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_tv8532)
+  AUTOLOAD:=$(call AutoProbe,gspca_tv8532)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-tv8532/description
- The TV8532 USB Camera Driver (tv8532) kernel module.
+ The TV8532 USB Camera Driver (tv8532) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-tv8532))
@@ -634,12 +656,12 @@ define KernelPackage/video-gspca-vc032x
   TITLE:=vc032x webcam support
   KCONFIG:=CONFIG_USB_GSPCA_VC032X
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_vc032x.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_vc032x)
+  AUTOLOAD:=$(call AutoProbe,gspca_vc032x)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-vc032x/description
- The VC032X USB Camera Driver (vc032x) kernel module.
+ The VC032X USB Camera Driver (vc032x) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-vc032x))
@@ -649,12 +671,12 @@ define KernelPackage/video-gspca-zc3xx
   TITLE:=zc3xx webcam support
   KCONFIG:=CONFIG_USB_GSPCA_ZC3XX
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_zc3xx.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_zc3xx)
+  AUTOLOAD:=$(call AutoProbe,gspca_zc3xx)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-zc3xx/description
- The ZC3XX USB Camera Driver (zc3xx) kernel module.
+ The ZC3XX USB Camera Driver (zc3xx) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-zc3xx))
@@ -664,12 +686,12 @@ define KernelPackage/video-gspca-m5602
   TITLE:=m5602 webcam support
   KCONFIG:=CONFIG_USB_M5602
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/m5602/gspca_m5602.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_m5602)
+  AUTOLOAD:=$(call AutoProbe,gspca_m5602)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-m5602/description
- The ALi USB m5602 Camera Driver (m5602) kernel module.
+ The ALi USB m5602 Camera Driver (m5602) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-m5602))
@@ -679,12 +701,12 @@ define KernelPackage/video-gspca-stv06xx
   TITLE:=stv06xx webcam support
   KCONFIG:=CONFIG_USB_STV06XX
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/stv06xx/gspca_stv06xx.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_stv06xx)
+  AUTOLOAD:=$(call AutoProbe,gspca_stv06xx)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-stv06xx/description
- The STV06XX USB Camera Driver (stv06xx) kernel module.
+ The STV06XX USB Camera Driver (stv06xx) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-stv06xx))
@@ -694,12 +716,12 @@ define KernelPackage/video-gspca-gl860
   TITLE:=gl860 webcam support
   KCONFIG:=CONFIG_USB_GL860
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gl860/gspca_gl860.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_gl860)
+  AUTOLOAD:=$(call AutoProbe,gspca_gl860)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-gl800/description
- The GL860 USB Camera Driver (gl860) kernel module.
+ The GL860 USB Camera Driver (gl860) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-gl860))
@@ -709,12 +731,12 @@ define KernelPackage/video-gspca-jeilinj
   TITLE:=jeilinj webcam support
   KCONFIG:=CONFIG_USB_GSPCA_JEILINJ
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_jeilinj.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_jeilinj)
+  AUTOLOAD:=$(call AutoProbe,gspca_jeilinj)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-jeilinj/description
- The JEILINJ USB Camera Driver (jeilinj) kernel module.
+ The JEILINJ USB Camera Driver (jeilinj) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-jeilinj))
@@ -724,12 +746,12 @@ define KernelPackage/video-gspca-konica
   TITLE:=konica webcam support
   KCONFIG:=CONFIG_USB_GSPCA_KONICA
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_konica.ko
-  AUTOLOAD:=$(call AutoLoad,75,gspca_konica)
+  AUTOLOAD:=$(call AutoProbe,gspca_konica)
   $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-konica/description
- The Konica USB Camera Driver (konica) kernel module.
+ The Konica USB Camera Driver (konica) kernel module
 endef
 
 $(eval $(call KernelPackage,video-gspca-konica))