mac80211: add RedPine RS9113 module support
[openwrt/openwrt.git] / package / kernel / mac80211 / patches / 400-ath_move_debug_code.patch
index 4cc77afa1b88ca4e7a197719fdb2a51428ef9f35..ed65053d7753f76b1997e9a96ab3b907f403260f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/Makefile
 +++ b/drivers/net/wireless/ath/Makefile
-@@ -13,8 +13,8 @@ ath-objs :=  main.o \
+@@ -13,10 +13,10 @@ ath-objs :=        main.o \
                regd.o \
                hw.o \
                key.o \
@@ -9,10 +9,12 @@
                dfs_pri_detector.o
  
 -ath-$(CPTCFG_ATH_DEBUG) += debug.o
- ccflags-y += -D__CHECK_ENDIAN__
+ ath-$(CPTCFG_ATH_TRACEPOINTS) += trace.o
+ CFLAGS_trace.o := -I$(src)
 --- a/drivers/net/wireless/ath/ath.h
 +++ b/drivers/net/wireless/ath/ath.h
-@@ -295,13 +295,6 @@ void _ath_dbg(struct ath_common *common,
+@@ -318,14 +318,7 @@ void _ath_dbg(struct ath_common *common,
  #endif /* CPTCFG_ATH_DEBUG */
  
  /** Returns string describing opmode, or NULL if unknown mode. */
@@ -25,4 +27,5 @@
 -}
 -#endif
  
- #endif /* ATH_H */
+ extern const char *ath_bus_type_strings[];
+ static inline const char *ath_bus_type_to_string(enum ath_bus_type bustype)