package/kernel: move block2mtd to block.mk
[openwrt/openwrt.git] / package / kernel / modules / block.mk
index ebd5d4ddef35293a2c7b66dec186cfd8190acf9b..f1074251abb41c427c479dce2f0f4daa989f4c86 100644 (file)
@@ -161,6 +161,16 @@ endef
 $(eval $(call KernelPackage,ata-via-sata))
 
 
+define KernelPackage/block2mtd
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Block device MTD emulation
+  KCONFIG:=CONFIG_MTD_BLOCK2MTD
+  FILES:=$(LINUX_DIR)/drivers/mtd/devices/block2mtd.$(LINUX_KMOD_SUFFIX)
+endef
+
+$(eval $(call KernelPackage,block2mtd))
+
+
 define KernelPackage/dm
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Device Mapper