package/kernel: arc4 needs blkcipher support on 3.6
[openwrt/openwrt.git] / package / kernel / modules / crypto.mk
index 43a7cc3431416d1fe486d64366f4629bf4df44d4..dc21c1d53a1bccfb7e173e6164ee4800801e4d40 100644 (file)
@@ -192,7 +192,7 @@ define KernelPackage/crypto-arc4
   KCONFIG:=CONFIG_CRYPTO_ARC4
   FILES:=$(LINUX_DIR)/crypto/arc4.ko
   AUTOLOAD:=$(call AutoLoad,09,arc4)
-  $(call AddDepends/crypto)
+  $(call AddDepends/crypto,+!LINUX_3_3:kmod-crypto-manager)
 endef
 
 $(eval $(call KernelPackage,crypto-arc4))