package the Winbond w83627hf super i/o controller
[openwrt/openwrt.git] / package / kernel / modules / fs.mk
index bfdd45a009b84c04ebe3ec8ba5a2b4a0fb33ad34..85b8e1ab8c636cf90e39f4a5a5674ec41099c155 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 FS_MENU:=Filesystems
 
@@ -113,6 +112,12 @@ endef
 
 $(eval $(call KernelPackage,fs-ext3))
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,2.6.28)),1)
+       EXT4_NAME:=ext4dev
+else
+       EXT4_NAME:=ext4
+endif
+
 define KernelPackage/fs-ext4
   SUBMENU:=$(FS_MENU)
   TITLE:=EXT4 filesystem support
@@ -121,11 +126,13 @@ define KernelPackage/fs-ext4
        CONFIG_EXT4_FS_XATTR=y \
        CONFIG_EXT4_FS_POSIX_ACL=y \
        CONFIG_EXT4_FS_SECURITY=y \
-       CONFIG_EXT4_FS
-  DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
+       CONFIG_EXT4_FS \
+       CONFIG_JBD2
+  DEPENDS:= @LINUX_2_6 +kmod-crc16 $(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
   FILES:= \
-       $(LINUX_DIR)/fs/ext4/ext4.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,ext4)
+       $(LINUX_DIR)/fs/ext4/$(EXT4_NAME).$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/fs/jbd2/jbd2.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,jbd2 $(EXT4_NAME))
 endef
 
 define KernelPackage/fs-ext4/description