comgt: add missing file (fixes #10301)
[openwrt/openwrt.git] / package / kernel / modules / hwmon.mk
index 1e97c3733a075dbf66f548cef65c334b3ffb36bc..57dd5684cbc44d30247bbee42641a92ef0ef2f2a 100644 (file)
@@ -10,12 +10,11 @@ HWMON_MENU:=Hardware Monitoring Support
 define KernelPackage/hwmon-core
   SUBMENU:=$(HWMON_MENU)
   TITLE:=Hardware monitoring support
-  DEPENDS:=@LINUX_2_6
   KCONFIG:= \
        CONFIG_HWMON \
        CONFIG_HWMON_DEBUG_CHIP=n
   FILES:= \
-       $(LINUX_DIR)/drivers/hwmon/hwmon.$(LINUX_KMOD_SUFFIX)
+       $(LINUX_DIR)/drivers/hwmon/hwmon.ko
   AUTOLOAD:=$(call AutoLoad,40,hwmon)
 endef
 
@@ -31,11 +30,25 @@ define AddDepends/hwmon
   DEPENDS:=kmod-hwmon-core $(1)
 endef
 
+define KernelPackage/hwmon-lm63
+  TITLE:=LM63/64 monitoring support
+  KCONFIG:=CONFIG_SENSORS_LM63
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm63.ko
+  AUTOLOAD:=$(call AutoLoad,60,lm63)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-lm63/description
+ Kernel module for lm63 and lm64 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm63))
+
 
 define KernelPackage/hwmon-lm75
   TITLE:=LM75 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM75
-  FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.ko
   AUTOLOAD:=$(call AutoLoad,60,lm75)
   $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
@@ -50,7 +63,7 @@ $(eval $(call KernelPackage,hwmon-lm75))
 define KernelPackage/hwmon-lm77
   TITLE:=LM77 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM77
-  FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.ko
   AUTOLOAD:=$(call AutoLoad,60,lm77)
   $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
@@ -65,7 +78,7 @@ $(eval $(call KernelPackage,hwmon-lm77))
 define KernelPackage/hwmon-lm90
   TITLE:=LM90 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM90
-  FILES:=$(LINUX_DIR)/drivers/hwmon/lm90.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm90.ko
   AUTOLOAD:=$(call AutoLoad,60,lm90)
   $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
@@ -76,6 +89,20 @@ endef
 
 $(eval $(call KernelPackage,hwmon-lm90))
 
+define KernelPackage/hwmon-lm95241
+  TITLE:=LM95241 monitoring support
+  KCONFIG:=CONFIG_SENSORS_LM95241
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm95241.ko
+  AUTOLOAD:=$(call AutoLoad,60,lm95241)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-lm95241/description
+ Kernel module for LM95241 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm95241))
+
 
 define KernelPackage/hwmon-pc87360
   TITLE:=PC87360 monitoring support
@@ -83,8 +110,8 @@ define KernelPackage/hwmon-pc87360
        CONFIG_SENSORS_PC87360 \
        CONFIG_HWMON_VID
   FILES:= \
-       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
+       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.ko \
+       $(LINUX_DIR)/drivers/hwmon/pc87360.ko
   AUTOLOAD:=$(call AutoLoad,50,hwmon-vid pc87360)
   $(call AddDepends/hwmon,@TARGET_x86)
 endef
@@ -102,8 +129,8 @@ define KernelPackage/hwmon-w83627hf
        CONFIG_SENSORS_W83627HF \
        CONFIG_HWMON_VID
   FILES:= \
-       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/hwmon/w83627hf.$(LINUX_KMOD_SUFFIX)
+       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.ko \
+       $(LINUX_DIR)/drivers/hwmon/w83627hf.ko
   AUTOLOAD:=$(call AutoLoad,50,hwmon-vid w83627hf)
 $(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86)
 endef