Add kmod-ppp-synctty (#2231)
[openwrt/openwrt.git] / package / kernel / modules / network.mk
index a7b93e1d4c28263ba03dbeeccdffd7862235594c..6da38e4e05c6e8b5e14f2a8c317b311ece5bae56 100644 (file)
@@ -189,6 +189,19 @@ endef
 $(eval $(call KernelPackage,ppp))
 
 
+define KernelPackage/ppp-synctty
+  TITLE:=PPP sync tty support
+  DESCRIPTION:=\
+       Kernel modules for PPP sync tty support
+  DEPENDS:=kmod-ppp
+  KCONFIG:=CONFIG_PPP_SYNC_TTY
+  SUBMENU:=$(NSMENU)
+  FILES:=$(LINUX_DIR)/drivers/net/ppp_synctty.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,40,ppp_synctty)
+endef
+$(eval $(call KernelPackage,ppp-synctty))
+
+
 define KernelPackage/pppoe
   TITLE:=PPPoE support
   DESCRIPTION:=\