ipsec{4,6} depend on kmod-crypto-aead to allow esp4 and esp6 to successfully load...
[openwrt/openwrt.git] / package / kernel / modules / sound.mk
index 11d816b366d671ffc933ec1282fbc0aa9b28e14f..547fddc8305fab3bfc86b42736081a655577d51b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,10 @@
 
 SOUND_MENU:=Sound Support
 
-# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@USB_SUPPORT||PCI_SUPPORT @!TARGET_atheros
+  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \
@@ -88,3 +87,19 @@ endef
 
 $(eval $(call KernelPackage,sound-i8x0))
 
+define KernelPackage/sound-cs5535audio
+  SUBMENU:=$(SOUND_MENU)
+  TITLE:=CS5535 PCI Controller
+  DEPENDS:=kmod-sound-core
+  KCONFIG:=CONFIG_SND_CS5535AUDIO
+  FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/sound/ac97_bus.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/sound/pci/ac97/snd-ac97-codec.$(LINUX_KMOD_SUFFIX) 
+  AUTOLOAD:=$(call AutoLoad,35, ac97_bus snd-ac97-codec snd-cs5535audio)
+endef
+
+define KernelPackage/sound-cs5535audio/description
+ support for the integrated AC97 sound device on olpc
+endef
+
+$(eval $(call KernelPackage,sound-cs5535audio))