add support for the dwc_otg USB controller
[openwrt/openwrt.git] / package / kernel / modules / usb.mk
index 8ce61f0f92d39a15c7ce7ca542bcf1c9245e77bc..8ec76f0d3652a5d053dbd3e77cb3c9facebfa6b2 100644 (file)
@@ -149,6 +149,20 @@ endef
 
 $(eval $(call KernelPackage,usb-etrax))
 
+define KernelPackage/usb-octeon
+  $(call usbdep,@TARGET_octeon)
+  TITLE:=Support for the Octeon USB OTG controller
+  KCONFIG:=CONFIG_USB_DWC_OTG
+  FILES:=$(LINUX_DIR)/drivers/usb/host/dwc_otg/dwc_otg.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,dwc_otg)
+endef
+
+define KernelPackage/usb-octeon/description
+  Kernel support for the Octeon USB host controller
+endef
+
+$(eval $(call KernelPackage,usb-octeon))
+
 
 define KernelPackage/usb2
   $(call usbdep,)