use $(FPIC) in a few places where it matters
[openwrt/openwrt.git] / package / libnl / Makefile
index f55d494a6360cb37fa5a3823a09e906566077da7..c763526f8a400f65da9b055526dd149bfc70f8ca 100644 (file)
@@ -29,6 +29,8 @@ define Package/libnl/description
  This package contains a library for applications dealing with netlink sockets
 endef
 
+TARGET_CFLAGS += -ffunction-sections $(FPIC)
+
 define Build/Compile
        $(call Build/Compile/Default)
        make -C $(PKG_BUILD_DIR) \
@@ -36,7 +38,7 @@ define Build/Compile
                install
 endef
 
-ifneq ($(CONFIG_LINUX_2_6_23)$(CONFIG_LINUX_2_6_24),)
+ifneq ($(CONFIG_LINUX_2_6),)
   define Build/InstallDev
        $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/