cyassl: update to wolfssl 3.12.2 (1 CVE)
[openwrt/openwrt.git] / package / libs / cyassl / Makefile
index 3cd8e4cfdf3a3d32631000f4fb6f2fa7c9c94a63..0212ff73d43f173b66707b5d57a0643894915bd1 100644 (file)
@@ -8,15 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wolfssl
-PKG_VERSION:=3.9.10
+PKG_VERSION:=3.12.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
 PKG_SOURCE_URL:=https://www.wolfssl.com/
-PKG_MD5SUM:=793921c0db96248be4a369cbfdf0cb7b37ee2be715b8b775b6cd32efe66f494e
+PKG_HASH:=4993844c4b7919007c4511ec3f987fb06543536c3fc933cb53491bffe9150e49
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
+PKG_USE_MIPS16:=0
 PKG_BUILD_PARALLEL:=1
 PKG_LICENSE:=GPL-2.0+
 
@@ -42,8 +43,8 @@ endef
 
 TARGET_CFLAGS += $(FPIC)
 
+# --enable-stunnel needed for OpenSSL API compatibility bits
 CONFIGURE_ARGS += \
-       --enable-singlethreaded \
        --enable-opensslextra \
        --enable-sni \
        --enable-stunnel \