libelf: fix library packaging
[openwrt/openwrt.git] / package / libs / gettext / Makefile
index 442eceff436a661b4640578bc374d028736e07cf..f37c4e4e740c94a7b3d21488650a74a844bf82c2 100644 (file)
@@ -13,7 +13,7 @@ PKG_RELEASE:=2
 PKG_LICENSE:=FSFULLR
 PKG_LICENSE_FILES:=LICENSE
 
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
@@ -24,11 +24,6 @@ define Package/libintl
   TITLE:=Stub header for the GNU Internationalization library
 endef
 
-define Build/Prepare
-       $(INSTALL_DIR) $(PKG_BUILD_DIR)
-       $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef      
-
 define Build/Configure
 endef
 
@@ -52,11 +47,11 @@ define Host/Compile
 endef
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/include
-       $(INSTALL_DATA) ./src/include/libintl.h $(STAGING_DIR_HOST)/include/
+       $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/include
+       $(INSTALL_DATA) ./src/include/libintl.h $(STAGING_DIR_HOSTPKG)/include/
 
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
-       $(INSTALL_DATA) ./src/m4/* $(STAGING_DIR_HOST)/share/aclocal/
+       $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/share/aclocal
+       $(INSTALL_DATA) ./src/m4/* $(STAGING_DIR_HOSTPKG)/share/aclocal/
 endef
 
 define Package/libintl/install