libelf: fix library packaging
[openwrt/openwrt.git] / package / libs / gettext / Makefile
index c2f4e756f9b99e9d379314b2b87e506b6bd02a86..f37c4e4e740c94a7b3d21488650a74a844bf82c2 100644 (file)
@@ -10,7 +10,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=gettext
 PKG_RELEASE:=2
 
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_LICENSE:=FSFULLR
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
@@ -21,11 +24,6 @@ define Package/libintl
   TITLE:=Stub header for the GNU Internationalization library
 endef
 
-define Build/Prepare
-       $(INSTALL_DIR) $(PKG_BUILD_DIR)
-       $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef      
-
 define Build/Configure
 endef
 
@@ -49,11 +47,11 @@ define Host/Compile
 endef
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/include
-       $(INSTALL_DATA) ./src/include/libintl.h $(STAGING_DIR_HOST)/include/
+       $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/include
+       $(INSTALL_DATA) ./src/include/libintl.h $(STAGING_DIR_HOSTPKG)/include/
 
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
-       $(INSTALL_DATA) ./src/m4/* $(STAGING_DIR_HOST)/share/aclocal/
+       $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/share/aclocal
+       $(INSTALL_DATA) ./src/m4/* $(STAGING_DIR_HOSTPKG)/share/aclocal/
 endef
 
 define Package/libintl/install